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ABSTRACT 

 

The way people express their thoughts is changing day by day. 3D animation is one of the new 

variations of these mediums. As modern technology is in its peak position right now, 3D 

animation process is now competent enough to express any story with the looks, colors and 

emotions of any real-life object or character. While our interest was in 3D animation, we also 

wanted to convey a message through a story relatable to our culture and society around us. So, 

we chose a story around child labor, which is a complex social problem in our country. It was 

our goal to articulate the story in a dynamic yet deep and understandable way through the 

whole process from story building to modeling, sculpting, texturing, rigging, animation, light 

setup, rendering and post processing. The final output  of this project is a video footage that 

combine all the work that is done hopefully expresses the idea behind making it. We hope, this 

project will redefine the idea of 3D animation in our country. 

 

 

 

 

 

 

 

 

 

 

 

 

 



v 
©Daffodil International University 

 

TABLE OF CONTENTS 

CONTENTS                                                                                               PAGE 
APPROVAL ......................................................................................................................... i 

DECLARATION ................................................................................................................. ii 

ACKNOWLEDGEMENT ................................................................................................... iii 

ABSTRACT ........................................................................................................................ iv 

TABLE OF CONTENTS ..................................................................................................... v 

LIST OF FIGURES ........................................................................................................... viii 

CHAPTER 

CHAPTER 1 .................................................................................................... 1 

Introduction ...................................................................................................................... 1 

1.1 Backstory: ............................................................................................................... 1 

1.2 Motivation: .............................................................................................................. 2 

1.3 Objectives: .............................................................................................................. 2 

1.4 Literature review: .................................................................................................... 3 

CHAPTER 2 .................................................................................................... 4 

Project Workflow ............................................................................................................. 4 

2.1 Modeling : ............................................................................................................... 4 

2.1.1 Switchboard ...................................................................................................... 4 

2.1.2 Water Filter : ..................................................................................................... 6 

2.1.3 Exhaust Fan : .................................................................................................... 7 

2.1.4 Hammer : .......................................................................................................... 8 

2.1.5 School Bench : .................................................................................................. 9 

2.1.6 Sidewalk & Walls: .......................................................................................... 10 

2.1.7 Mold Machine : ............................................................................................... 11 

2.1.8 Toy and Real Cars : ......................................................................................... 13 



vi 
©Daffodil International University 

 

2.1.9 School Gate : .................................................................................................. 15 

2.1.10 Character Modeling : ..................................................................................... 15 

2.1.11 Shelf : ........................................................................................................... 18 

2.1.12 Plastic Basket : .............................................................................................. 19 

2.1.13 Electric Pole : ................................................................................................ 19 

2.2 UV Unwrap ........................................................................................................... 21 

2.2.1 Switchboard : .................................................................................................. 21 

2.2.2 Water Filter : ................................................................................................... 23 

2.2.3 Exhaust Fan : .................................................................................................. 23 

2.2.4 Hammer : ........................................................................................................ 24 

2.2.6 Sidewalk & Walls: .......................................................................................... 25 

2.2.7 Mold Machine : ............................................................................................... 26 

2.2.8 Toy and Real Cars : ......................................................................................... 28 

2.2.9 School Gate : .................................................................................................. 29 

2.2.10 Character Unwrap : ....................................................................................... 29 

2.3 Texturing ............................................................................................................... 32 

2.3.1 Switchboard : .................................................................................................. 32 

2.3.2 Water Filter : ................................................................................................... 34 

2.3.3 Exhaust Fan : .................................................................................................. 35 

2.3.4 Class Bench : .................................................................................................. 37 

2.3.5 Sidewalk and Walls : ....................................................................................... 38 

2.3.6 Mold Machine : ............................................................................................... 39 

2.3.7 Toy Cars : ....................................................................................................... 40 

2.3.8 Pliers : ............................................................................................................. 40 

2.3.9 School Building : ............................................................................................ 42 

2.4 Lighting ................................................................................................................. 43 



vii 
©Daffodil International University 

 

2.5 Render Settings : ................................................................................................... 52 

CHAPTER 3 .................................................................................................. 54 

Limitations and Challenges ............................................................................................. 54 

3.1 Limitations: ........................................................................................................... 54 

3.2 Challenges: ............................................................................................................ 55 

CHAPTER 4 .................................................................................................. 56 

Some Problems and Solutions ......................................................................................... 56 

CHAPTER 5 .................................................................................................. 58 

Conclusion ...................................................................................................................... 58 

REFERENCES ............................................................................................. 59 

 



viii 
©Daffodil International University 

 

LIST OF FIGURES 

FIGURES                                                                                                                PAGE NO 

Figure 2.1 Switch and socket model 5 

Figure 2.2 Switchboard model 5 

Figure 2.4 Water filter model 7 

Figure 2.6 Exhaust fan model 8 

Figure 2.7 Hammer model 9 

Figure 2.8 Classroom bench model 10 

Figure 2.9 Sidewalk and walls model 11 

Figure 2.10 Base part of mold machine 11 

Figure 2.11 Complete mold machine model 12 

Figure 2.12 Basic shape of toy car 13 

Figure 2.13 Complete shape of the toy car 14 

Figure 2.14 Complete real car model 14 

Figure 2.15 School gate model 15 

Figure 2.16 Character basic shape 16 

Figure 2.17 Smooth mesh preview of character’s body 17 

Figure 2.18 Complete character model 18 

Figure 2.19 Steel shelf model 18 

Figure 2.20 Plastic basket model 19 

Figure 2.21 Electric pole model 20 

Figure 2.22 Electric pole wire model 20 

Figure 2.24 Switchboard uv unwrapping 22 

Figure 2.25 Water filter uv unwrapping 23 

Figure 2.26 Exhaust fan unwrapping 24 

Figure 2.27 Hammer model unwrapping 24 

Figure 2.28 School bench unwrapping 25 

Figure 2.29 Sidewalk and walls unwrapping 26 

Figure 2.30 : 0 to 1 space for layout all uv shells 27 

Figure 2.31 Mold machine unwrapping with 3 udim tiles 28 

Figure 2.32 Toy car model unwrapping 28 



ix 
©Daffodil International University 

 

Figure 2.33 School gate model uv unwrapping 29 

Figure 2.34 Character body uv unwrapping 30 

Figure 2.35 Character dress uv unwrapping 31 

Figure 2.36 Switch board texturing in substance painter 32 

Figure 2.37 Switch board assigned texture in maya 33 

Figure 2.38 Switch board rendered image in autodesk maya 34 

Figure 2.39 Water filter texturing in substance painter 34 

Figure 2.40 Water filter rendered image in autodesk maya 35 

Figure 2.41 Exhaust fan texturing in substance painter 36 

Figure 2.42 Exhaust fan rendered image in autodesk maya 36 

Figure 2.43 Class bench texturing  in substance painter 37 

Figure 2.44 Class bench rendered image in autodesk maya 37 

Figure 2.45 Sidewalk and walls texture assigned image in autodesk maya 38 

Figure 2.46 Sidewalks tiles texturing in substance painter 38 

Figure 2.47 Three different udim texture set of mold machine 39 

Figure 2.48 Layers of three different texture set list of mold machine 39 

Figure 2.49 Toy car texturing in substance painter 40 

Figure 2.50 Pliers texturing in substance painter 41 

Figure 2.51 Pliers render image with texture in autodesk maya 41 

Figure 2.52 Bump map creating for bricks in adobe photoshop 42 

Figure 2.53 School building rendered image in autodesk maya 42 

Figure 2.54 Directional light parameters of first scene 43 

Figure 2.55 Sky dome light parameters of first scene 44 

Figure 2.56 Spot light parameters of classroom scene (outdoor) 45 

Figure 2.57 Area light parameters of classroom scene (indoor) 46 

Figure 2.58 Spot light parameters of factory scene (indoor) 46 

Figure 2.60 Combination of indoor and outdoor lights 48 

Figure 2.61 First scene final rendered image 48 

Figure 2.62 Second scene final rendered image 49 

Figure 2.63 Classroom final rendered image 49 

Figure 2.64 Main factory final rendered image 50 

Figure 2.65 Factory storage room final rendered image 50 



x 
©Daffodil International University 

 

Figure 2.66 Last scene final rendered image 51 

Figure 2.67 Default arnold sampling parameters 52 

figure 2.68 Final render setup and sampling parameters 53 

figure 2.69 Final aovs for all scenes 53 



1 
©Daffodil International University 

 

CHAPTER 1 

Introduction 

1.1 Backstory: 

Animation by definition is created by generating a chain of drawings or pictures taken by some 

sort of simulation procedure for creating movement. It creates an optical illusion through 

which we are able to see still images or drawings moving. 3D Animation is animating objects 

in a three-dimensional space, usually created via software which can be rotated and moved 

like real objects. A motion picture is considered one of the most common methods of 

presenting animation. 

 

The story we developed titled “Through the Window” was decided to be made as a 3D 

animation because it was the most efficient way to convey our message. This project was 

heavily inspired by some animated short films by independent artists and studios like “In a 

Heartbeat”[1] from Ringling college, “Piston”[2] from ESMA Productions, “Coin Operated”[3] 

Written & Directed by Nicholas Arioli and “Mr. Indifferent” [4] from BadStache Animation 

Studio. 

 

“Through the Window” is a one and a half minute long 3D animated short film which contains 

cartoon style characters in two different realistic environment or sequences. First sequence 

will be a school environment with adequate lighting and the second sequence will be a small 

congested old town cheap toy factory environment in dark lighting. 

 

The story of the short film will portray the incidence of child labor in our society. In the first 

sequence a school boy plays with his new toy car on his way to school and on his way home 

from school he stumbles upon another boy of his age who was having a hard time making that 

very same toy car in a factory. This project will bring out the brutal reality of our socio- 

economic situation in front of people's eyes, about how regardless of age people have to work 

for minimum wages even when they are school-going age. 
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1.2 Motivation: 

Now-a-days child labor has become normalized in our society. In this project both realities of 

the lives of privileged and underprivileged children will be shown side by side for comparison. 

This stark comparison will effectively communicate the circumstances that cost the basic right 

of education for an underprivileged child to the viewers. 

 

In our society it is not uncommon to see children working instead of going to school just to 

feed themselves. Some employers make them work so much as though they were adults while 

they would never let their own children go through the same situations. It is the hypocrisy of 

the people with lower morals and no ethical standards. This regular but pathetic sight was the 

motivation behind developing such a story and make it into a 3D animation. 

 

1.3 Objectives: 

Objectives of this project are: 

1. Create different props models 

2. Create 3D characters with attractive, adorable features 

3. Create two different environments to portray the story appropriately 

4. Texture the models to make them look as close to real objects as possible 

5. Rig and skin paint the characters to make them workable models for animation 

6. Animate the characters with proper body language and facial expressions 

7. Light the scenes properly for the maximum resemblance with real environment 

8. Render the animated frames in proper quality and format 

9. Color grade and assemble the scenes 

10. Add sound effects to enhance the experience 

11. Portray the social situation of child labor through 3d animation 

12. Create awareness about child labor in a relatable way 
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Although the output of this project is a 3D animation but it is not necessarily targeted towards 

children. The target audience of this project are people of age thirteen and up but people of 

any age can watch the film and enjoy it. 

1.4 Literature review: 

 

Several 3D animations have been consulted to offer an in-depth analysis of the best 

methodology for the film. In the film "In a Heartbeat" Beth David and Esteban Bravo used a 

specific pattern for the environment in their film. Everything had a “Heart” shaped feel to 

them. The idea of selecting a pattern and stylizing all the props and environment according to 

that was inspiring. Some films use semi realistic environment style such as “Piston” of ESMA 

productions whereas others use super realistic background environment like that of Badstache 

studios “Mr. Indifferent”. Luke Snedecor & Sarah Heinz at Chapman University created 

“Preheated” [5] which portrayed a child character, which is a wonderful reference. The 

animated short film "Alike"[6],directed by Daniel Martínez Lara & Rafa Cano Méndez, used a 

minimal but stylized background environment with the unique idea of rounded edged 

buildings. "Watermelon A Cautionary Tale"[7] by Kefei Li & Connie Qin He had amazing 

animation and lighting but the background props were not much detailed and there were some 

noticeable mistakes where surfaces which were supposed to collide goes through each other 

instead. Problems like these inspired us to be looked into to eliminate in our film. 3D animated 

short film “The Present”[8] was based on a great little comic strip by the very talented Fabio 

Coala. This film has excellent texture and lighting. Most of these films had a subtle depth of 

field as per needed in each scene which gives us a challenge to obtain. By studying all of these 

films and more we have chosen the best combination of designs, textures and environments to 

portray our story vividly and comprehensively. 
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CHAPTER 2 

Project Workflow 

 

In this chapter I’ll discuss about all the software and process used for this project. It includes 

modeling, uv, texturing, lighting and rendering. Necessary details about “Adobe 

Photoshop”[9],“Autodesk Maya”[10],“Substance Painter”[11] will be given as these are the 

software, I have used to complete the following process. 

 

2.1 Modeling : 

3D Modeling is the process of creating the faces of an object in 3-dimensional space within 

3D software. There are a few types of modelling which includes Polygonal and Nurbs 

modeling. But for this project we chose polygonal modeling because it is more popular and 

more familiar to us. In this modelling process standard primitives like boxes, spheres and 

cylinders are used and modified to make various models. For modification, tools like extrude, 

bridge, combine and deformers like bend, lattice etc. are used. While modelling all the props 

and characters it is strictly followed that all the polygons should be in quads. Because   The 

description of the models I made are given below. 

 

2.1.1 Switchboard : 

The switch board is made for the factory scene. The style of this switchboard is vintage, to 

make the factory look more realistic. There are two different parts in the board. One is the 

switch and the other is the socket. 

For the switch, I have used pCylinder. Gave it an appropriate radius according to the real-life 

switch size. In the middle of the switch there is a separate Box which I took to make the on/Off 

button. Then I made the socket in the same way as the switch but this time I made three holes 

in it to make it look like a socket. The socket radius is bigger than the switch radius. The 

bottom part of both this switch and socket are deleted to make the polycount less. I have put 

supporting edge loop where it’s needed before making it smooth mesh. 
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Figure 2.1 Switch and Socket Model 

 

To hold all this switch and socket together, I created a box from six pCubes. This pCubes are 

modified to make it look like one single box. The edges were beveled and added support loops 

to smooth the mesh. 

 

 

Figure 2.2 Switchboard Model 
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2.1.2 Water Filter :  

The Water filter is also made for factory scene. For making it, first I took one pCylinder. It 

had 12 Subdivision axes by default and it was enough for me to manipulate it. 

The top and bottom polygons of the cylinder was removed in order to make the shape of water 

filter. To make the top of the water pot, I selected the open edge of the top part then extruded 

and scaled inward by pressing Shift + Drag with scale tool selected. I used this same extrude 

technique to make the shape of the water pot. 

The water pot holder also has a water tap which I made by little modified pieces of 

polyCylinder. 

Every piece of the water filter was made with a low subdivision first. After the final 

modification was done, I subdivided every piece of the filter to give it enough edge flow for 

the help of texturing. For the water pot holder, I again used polyCylinder with 12 Sub Axis. 

 

 

Figure 2.3 Water Pot and Pot Holder Model 

 

The bottom polygons were deleted because they weren't going to be seen in camera. For the 

upper part of the pot holder, I deleted those top polygons first, then started to scale down the 

upper part of the cylinder to make it as the reference image was. 
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Figure 2.4 Water Filter Model 

2.1.3 Exhaust Fan :  

The exhaust fan was modeled for the exhaust system in the factory. This fan has two separate 

pieces. One is the blade and the other is the frame which holds the blade. First, I modeled the 

blade.  

Figure 2.5 Propeller and Frame Model 

I took one polyCylinder and added enough subdivision in both axis and height to do the next 

part. Then I selected the vertex mood in Maya by clicking the right mouse button. I had to 
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rotate each subdivision height in order to make a twisted look so that I can extrude four wings 

from those twisted polygons. Then I selected the polygons which I needed to extrude and 

extruded those according to the reference. 

The middle part of the blade was extruded down according to the design of the fan. After 

making the basic form of the blade I gave it enough resolution by subdividing it. 

The frame of the fan was made from a pipe. I increased the subdivision height and width 

according to my need. Then extruded some polygons of that pipe according to the reference 

image. 

 

 

Figure 2.6 Exhaust Fan Model 

 

2.1.4 Hammer : 

The hammer was designed as a tool in the factory. It’s a simple hammer which have two 

different parts in the final model. One is the hammer head and another is the handle. 
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Figure 2.7 Hammer Model 

 

The modeling part of the handle was easy because it was made out of a single box which was 

then manipulated with some edge loop. Although making the hole in the handle was a little bit 

difficult. 

The head of the hammer was difficult to make because it is a combination of three different 

primitives(Box, Sphere, Cylinder ).I took those three primitives and make them look like the 

head by manipulating them in vertex and edge mood. Some polygons were deleted in order to 

combine those three primitives. For combining those I used merge vertices operation by Shift 

+ Right mouse button >Merge Vertices >Merge Vertices. It was mandatory to stay in vertex 

mood in order to use merge vertices operation. 

 

2.1.5 School Bench : 

These benches were made for the classroom scene. It has 2 different parts which have Metal 

and Wood part. The wood part was quite simple to make. It has only a box which was 

subdivided to make enough  edge. Sharp corners of the box were chamfered to make it realistic 

because in the real world no object have blade sharp edge. To chamfer/bevel, select the edge, 

Shift + Right mouse button>Bevel Edge. There are three parts of wood in one bench. One is 

the table top, the second one is for sitting and the last one for resting your back. 
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The second part of the bench was the steel part which has lots of bending going on. So, to bend 

the frame according to the design, I used the bend option from Menu→ Deform→ Nonlinear 

→Bend. I also made some screws to make the joints more realistic. That screw was made out 

of sphere which was cut in half and extruded to match the shape of a screw. 

 

 

Figure 2.8 Classroom Bench Model 

 

2.1.6 Sidewalk & Walls: 

These things were made from the reference of our everyday lives. The tiles of the sidewalk 

were modeled one by one with the dimensions of 10 inch by 10 inches. There are two different 

types of tiles with two different design. 

Although the same result could have been achieved by using texture and bump maps. 

The walls were pretty simple to make. It's just a box with the top portion extruded a little bit. 

To do this, first insert an edge loop(Shift + Right Mouse Button →Insert edge loop tool)in the 

top portion of the wall then select the right face and extrude (Ctrl + E) it outward. In the end, 

smooth the mesh by pressing 3 in your keyboard. 
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Figure 2.9 Sidewalk and Walls Model 

2.1.7 Mold Machine : 

This model is one of the key models because our story is related to it. So, this model took a lot 

of time to make with so many small details. There are many different parts of this mold 

machine. In fact, it was made to perform an animation of its own. 

 

 

Figure 2.10 Base part of Mold Machine 

 



12 
©Daffodil International University 

 

To complete this model, I have used so many basic shapes like box, cylinder, torus, pipe etc. 

As you can see in the picture, first I created the base of the mold machine which are just some 

boxes. Basically, I beveled the side edge and make each box smooth by pressing 3 on my 

keyboard. After the base part, I made those cylinders according to the reference. After these 

base and cylinder parts, there are some technical parts which I have modeled to do some 

animation. According to the design there were some holes. To make those holes I have used 

the Bridge command. For each and every part of the mold machine, maintaining the topology 

was the main thing because without a good topology I wouldn't be able to perform the smooth 

mesh command. And without smoothing the mesh, the model would look so unrealistic. 

 

In mold of the mold machine from which the plastic cars come out is in the middle of the mold 

machine. For creating the mold part, I have used the model of the plastic car which I made for 

our short film. I combined and merged that car model with a box which together made the 

mold. 

 

 

Figure 2.11 Complete Mold Machine Model 

To combine any object with another object, first select those objects you want to combine, 

then under the Modeling Set >Mesh >Combine. And to perform the merge operation, select 
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the vertices you want to merge together and Shift + Right Mouse Button > Merge vertices > 

Merge vertices. 

 

2.1.8 Toy and Real Cars : 

There are two different cars which I modeled for this project. One is for our main character 

Shanto and another is for our side character Milli. Both cars have different designs and pattern. 

 

 

Figure 2.12 Basic Shape of Toy Car 

 

The basic shape needed to be so low poly which make the modeling tough to manipulate the 

shape. But its needed because after making the mesh smooth, the subdivided mesh will have a 

lot of polygons. 
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Figure 2.13 Complete Shape of the Toy Car 

 

First, I downloaded a good reference then started to make the shape of the car from a simple 

primitive box. I have used Insert Edge Loop Tool to manipulate the box as the design needed. 

Select any object, press Shift + Right Mouse Button >Insert Edge Loop Tool. 

 

 

Figure 2.14 Complete Real Car Model 
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I have also used the Multi-Cut tool to cut the geometry where it’s needed to be cut. For 

example, the round space for the wheels to rotate in the car body. 

2.1.9 School Gate : 

Modeling the school gate comes with some challenges. These two pillars were made out from 

a box which have the same height and width of a real gate. For design purpose I added some 

edge in middle and extruded some faces inward to make it look good. Then I added some 

support edge loop to smooth the mesh. The lights were made out from sphere and the base 

from cylinder. SCHOOL letters were created in Maya with the help of polygonal text. 

Shelf >Poly Modeling >Polygon Type: Create polygonal text on the grid .Then type in attribute 

editor what you want to right. 

 

 

Figure 2.15 School Gate Model 

 

2.1.10 Character Modeling : 

There is a total of four characters in our 3d animation film. One of them is our main character 

Shanto who is a boy. A character model is separated into different parts - Head, Torso, Legs, 

Arms, Feet and Hands. 
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The torso is made out of a pCylinder with 8 subdivisions, head was made of a pSphere with 

12 subdivisions, arms and legs were created with pCylinders with 8 subdivisions. Hands are 

made of pCubes. 

 

Character building process starts with the torso part. First the cylinder is shaped to match with 

the reference picture by adding edge loops wherever it is necessary. This process includes the 

transform and scale commands mostly with “object x” selected in the symmetry menu from 

the menu bar. When modeling the character, it should be kept in mind that the model needs to 

match with only one side of the reference image. Because after one side is perfectly matched 

the faces of the other side are deleted from the middle. Then selecting the faces of the other 

side, the pivot point is moved and snapped to the center of the grid by pressing d and x on the 

keyboard. Then from the dropdown edit menu duplicate special option is selected and value 

of scale x is set to -1 and applied. This duplicate and mirrors all the faces and positions them 

to 0 point on the grid as the pivot point was previously set there. 

After doing the duplicate operation, the middle vertices must be merged because otherwise the 

smooth mesh will show odd results. 

 

 

Figure 2.16 Character Basic Shape 

To merge any vertex with other vertex, select those and press Shift +Right Mouse Button 

>Merge vertices >Merge vertices. After this the history of the object must be deleted. To delete 
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history, go to Menus >Edit >Delete by type >History. After doing the base shape it was just a 

matter of time to move and adjust every vertex and edge loop according to the reference image. 

 

For the face I used a sphere with 12 subdivisions and merge it with the body. Then modified 

it by deleting and creating holes for the eyes. Nose and mouth. 

 

 

Figure 2.17 Smooth Mesh Preview of Character’s Body 

 

To create the dress, first the character body is duplicated on place. Then it is extruded to make 

it bigger than the body and all the unnecessary faces are deleted. It gives a primary shape of a 

garment. For each piece of garment, the body needs to be duplicated separately. This process 

provides enough polygons to model the garments perfectly. 
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Figure 2.18 Complete Character Model 

 

2.1.11 Shelf : 

The shelf is made out of some basic primitives. I have used simple boxes to make all the shapes 

of the shelf. I have used the Insert Edge Loop tool to put edge loop where it’s necessary. Then 

extruded some parts to match the reference image. 

 

 

Figure 2.19 Steel Shelf Model 
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2.1.12 Plastic Basket : 

The basket was pretty simple to make. To make this basket first take a box and select the face 

in the top. Press Ctrl + E to enable extrude mood then press any or the colored square in the 

gimbal to enable inset mood. Inset a little bit then extrude it down to make the belly of the 

basket. After that to make the design in the body of the basket just insert some edge loop as 

you want and extrude some faces according to the design. At last give some supporting loops 

to the existing edge loop so that after performing the smooth mesh operation, it can hold its 

original shape. Then press 3 on your keyboard to smooth it. 

 

 

Figure 2.20 Plastic Basket Model 

2.1.13 Electric Pole : 

The electric pole was created for the outdoor scene. It’s a combination of a cylinder, some 

boxes and some small pipes which was modified to make those small parts in top. The height 

of the pole is around 25 feet. First, I took one cylinder with a subdivision of 12.The top and 

bottom part of the cylinder was deleted to reduce the file size. Then I selected the vertex mood 

and scaled down the top vertices a little bit according to the design. The wires were made out 

of cylinders too. I inserted some edge loops in one long cylinder around 40 feet long and 
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selected the middle vertices. Then turn on the soft selection by double clicking on the selection 

tool.  

 

Figure 2.21 Electric Pole Model 

 

Adjust the soft selection level according to the need. After that I pulled those vertices to 

make them carved from middle to look like wires. In top of the pole, there are two wood 

bars. To make those I just used one box and beveled the edges to look realistic. 

 

 

Figure 2.22 Electric Pole Wire Model 
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2.2 UV Unwrap  

 

Unwarp is one of the popular methods for doing UV of any 3d object. UV means representing 

a 3d object's surface with a flat 2d surface. It’s used to texture 3d objects easily. This process 

of creating a uv map is called UV unwrapping. 

Here the U and V represent two axes of the 2d space. And in the 3d space there are 

three(X,Y,Z) axes which represent 3 different directions. 

 

2.2.1 Switchboard : 

Each and every component in switch board was unwrapped for the texturing purpose. First 

selected the switch, then choose the right edge which needed to be cut for making the seam. 

To make the cut, open the UV editor from Windows > Modeling Editors> UV Editor. Then 

with the right edge selected, press SHIFT + X to make the cut. After cutting all the necessary 

edge to unfold the switch, press CTRL + U while shell mood is  selected in the UV Editor. 

That unfolded the switch properly but sometimes it needed to be optimized in order to unfold 

perfectly. Optimize tool will be found in the UV Toolkit > Unfold > Optimize. To orient the 

shells, Select the shells you want to orient >Open up the UV Toolkit >Arrange and Layout 

>Orient Shells. This will make all the shells oriented which will make the texturing process 

easier. 
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Figure 2.23 Switch UV Unwrapping 

 

As some of the switches are identical, so in order to save space in 0 to 1 space I used Stack 

and Orient Operation to stack those same unfolded uv shells. It’s located in UV Toolkit 

>Arrange and Layout >Stack and Orient. 

 

 

Figure 2.24 Switchboard UV Unwrapping 
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2.2.2 Water Filter : 

Water filter have around five to seven part including some small pieces. So, each piece needed 

to be cut according to the need of texturing and unfolding. After selecting the edge, you want 

to cut, Open UV Editor and press Shift +X and press Ctrl + U to unfold the object properly in 

2d surface. 

 

 

Figure 2.25 Water Filter UV Unwrapping 

 

Sometimes the unfold may not be perfect, so to fix that use the Optimize tool from UV Toolkit 

>Optimize. This will fix any odd stretched unfolding problem and make the cut shells perfectly 

flat. 

 

2.2.3 Exhaust Fan : 

The unwrap process is almost the same for every model, the difference is to find the perfect 

seam spot where the cut will be less visible. For the exhaust fan, all components were cut and 

unwrapped one by one. By selecting the seam edge press Shift + X on the UV Editor window 

to cut the selected edges. Select all the UV Shells and press Ctrl + U to unwrap and press  Shift 

+ Right Mouse Button > Orient Shells. At last press Ctrl + L to lay out all the shells. 
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Figure 2.26 Exhaust Fan Unwrapping 

 

2.2.4 Hammer : 

Unwrapping the hammer was not so difficult because it doesn't have a lot of components. It 

has two components. The head and the body. First select the edge which will be the seam and 

cut it by pressing Shift + X in UV Editor and then Unfold it by pressing Ctrl +U. 

 

 

Figure 2.27 Hammer Model Unwrapping 
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2.2.5 School Bench : 

 

 

Figure 2.28 School Bench Unwrapping 

 

The school bench had two different parts to unwrap. One is the steel parts and the other one is 

the wood part. Both of these things were cut and unfolded as the previously mentioned process. 

 

2.2.6 Sidewalk & Walls: 

Sidewalk has three components to unfold which were basically two types of tiles and one 

cement block. These things were already almost flat so it didn’t need to be cut. Only by 

pressing Ctrl +U it was unfolded properly. 
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Figure 2.29 Sidewalk and Walls Unwrapping 

 

The walls have also almost same geometry because the back faces were deleted to make the 

scene optimized. It was pretty flat already so just pressing the Ctrl +U it unfolded 

automatically. 

 

2.2.7 Mold Machine : 

Unwrapping the mold machine was not easy because it has a lot of components in it . And in 

uv editor there needs to be some space management because texture resolution depends on it. 

For normal small models the preferred space is 0 to 1 space. It means all the parts of the models 

needs to be fit in the shown space below. 
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Figure 2.30 : 0 to 1 Space for Layout All UV Shells 

 

But as the mold machine has a lot of parts, it was difficult to fit all those parts in 0 to 1 space. 

So, I used some more space to fit those all. This type of texture set is called UDIM Texture 

“UDIM was invented by Richard Addison-Wood and came from Weta Digital (circa 2002). 

The term UDIM comes from U-Dimension and design UV ranges. The UV range 0-1 being 

1001, the range 1-2 being 1002, and so on. We designate by UDIM Tile a specific range, the 

tile 1001 being the range 0-1 of a given mesh. The goal of having multiple UV ranges it 

to increase the texture resolution of a given mesh. Instead or working with very big textures 

(16K, or even 32K) which are hard to optimize it is instead better to split a mesh into sub-

parts. Because of the UDIM naming convention, parsing files is easy as the ID of a tile is 

embedded into the filename, which make them convenient to use in external rendering 

software such as V-ray or Arnold.”[12] .UDIM uses more than one tile of UV Editor to lay out 

every part of any model. For cutting every necessary edge to make the seam, select the object 

then select the edge. 

Go to Menu >Windows >Modeling Editors >UV Editor. Press Shift + X to make the cut and 

Ctrl +U to unfold the part properly. This same process was repeated for every part of the mold 

machine. Each and every piece needs to be unfolded properly otherwise the texture will give 

some odd results. I needed three UDMI tiles to fit all those parts of the mold machine. 
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Figure 2.31 Mold Machine Unwrapping with 3 UDIM Tiles 

2.2.8 Toy and Real Cars : 

As the toy car needed to have stickers in its body, so it was important to unfold it in one single 

piece so that no seam can be seen in stickers. To do this I had to cut some of the edge according 

to the need by pressing Ctrl + U and then gave it some optimization with the optimize tool 

from the UV Toolkit. 

 

Figure 2.32 Toy Car Model Unwrapping 
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The real car model was also modified from this toy car so the UV Unwrapping has the same 

process described in for the toy car. 

 

2.2.9 School Gate : 

The school gate has some small and big components in it including some words. So, the 

columns in two side was unwrapped just like a box. The different words have different ways 

to cut for unwrap. 

 

Figure 2.33 School Gate Model UV Unwrapping  

 

2.2.10 Character Unwrap : 

Character unwrapping is not that much tough how its look like. It has some simple ways to do. 

You just need to understand where to cut and where not. Every piece of the body can be 

unwrapped by cutting the following edges shown below. First there needs to be cut made in 

every single joint. Started by cutting the edge around the thighs where the thigh joins with the 

torso. Then the arms are cut along the edge that joins them with shoulders. 
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Figure 2.34 Character Body UV Unwrapping 

 

After that the head is separated by cutting around the neckline. Hands are cut along the wrist 

and the feet are cut along the ankles. For flattening the head, a cut is made behind the head 

starting from the hairline. 

 

After making the cuts were done it was time to unfold the UVs. It was unfolded following the 

steps previously mentioned. Then the layout was done manually to make it easier for texturing 

later. 
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Figure 2.35 Character Dress UV Unwrapping 

 

For unwrapping the dress, it was done one by one. First the shirt was selected and edges along 

the sides were cut. When unfolded , it easily split into two equal symmetric halves. Similarly, 

the pants were unfolded. In this case all the clothes were kept in the same 0-10 space in the uv 

editor to save some space. 
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2.3 Texturing 

 

Texturing is a method of creating high quality detail, surface texture or color information on a 

computer generated 3d model or graphic. For our project we have used “Adobe Substance 

Painter”[13] to texture most of our models. It works layer by layer and makes texture easy. 

Adobe Substance Share website helped a lot because it had a lot of free materials in it.  

 

2.3.1 Switchboard : 

The texturing part was done in Substance Painter in order to have more control over the 

materials and textures. I needed to export the whole switchboard in fbx format from Autodesk 

Maya to Substance Painter. There were two different kinds of materials needed in the switch 

board. One is the wood texture and the other is the plastic material.   

 

 

Figure 2.36 Switch Board Texturing in Substance Painter 

 

In order to import the fbx switchboard in Substance Painter, go to File> New> Select the fbx 

switchboard file and give it an appropriate resolution then press OK. First, we need to bake 

mesh maps for the model. For creating new materials in Substance Painter, go to Layers tab > 

Add a fill layer> Material. There I can modify base color, metalness, roughness, normal and 
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height. After creating the materials properly according to the need, I exported those texture 

maps for Autodesk Maya. For Export textures; File> Export Textures. A new tab will be 

opened and there some options needs to be changed according to the requirements. Like 

format, size etc. of those exported textures. 

 

 

Figure 2.37 Switch Board Assigned Texture in Maya 

 

The switchboard at the top have all the png textures assigned in Maya which was created in 

Substance painter. In Maya I used aiStandardSurface Material for rendering every model. The 

picture below shows the fully rendered image of the switchboard with Arnold Renderer. 
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Figure 2.38 Switch Board Rendered Image in Autodesk Maya 

 

2.3.2 Water Filter : 

In order to import the fbx switchboard in Substance Painter, go to File> New> Select the fbx 

switchboard file and give it an appropriate resolution then press OK. 

 

 

Figure 2.39 Water Filter Texturing in Substance Painter 
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First, we need to bake mesh maps for the model. For creating new materials in Substance 

Painter, go to Layers tab > Add a fill layer> Material. 

 

Figure 2.40 Water Filter Rendered Image in Autodesk Maya 

 

2.3.3 Exhaust Fan : 

First the fbx format file of the exhaust fan was exported from Maya then imported into 

substance painter with the UV information. To import the fbx file in Substance Painter , go to 

File > New > From the Template select the file you want to import >give it a resolution >Ok. 

After importing it with one resolution it can be changed anytime.   
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Then we need to bake mesh maps for the model. For creating new materials in Substance 

Painter, go to Layers tab > Add a fill layer> Material. 

 

 

Figure 2.41 Exhaust Fan Texturing in Substance Painter 

 

Smart materials were used because it stays contained in layers and it can be modified easily. 

 

 

Figure 2.42 Exhaust Fan Rendered Image in Autodesk Maya 
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2.3.4 Class Bench : 

The importing and baking techniques are the same as the previous models. But for this school 

bench I have used two UDIM sets to export textures from Maya. So, when importing fbx 

 

 

Figure 2.43 Class Bench Texturing  in Substance Painter 

 

file in Substance painter, you need to click on “Create a texture set per UDIM tile”. 

 

 

Figure 2.44 Class Bench Rendered Image in Autodesk Maya 
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2.3.5 Sidewalk and Walls : 

These textures were done in Substance painter with multiple layers. It’s needed to look a 

little bit old so some dirt layers were applied on top of the clean materials. 

 

 

Figure 2.45 Sidewalk and Walls Texture Assigned Image in Autodesk Maya 

 

As it has four different components, so four different types of materials needed to be created 

for them. As you can see down below, the red tiles have 4 different layers in total. 

 

 

Figure 2.46 Sidewalks Tiles Texturing in Substance Painter 
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2.3.6 Mold Machine : 

As the mold machine has three UDIM tiles, it was difficult to texture because every set of 

UDIM needs to be textured separately. It’s because every UDIM will be in different layers 

which can be found under Texture Set List tab. 

 

 

Figure 2.47 Three Different UDIM Texture Set of Mold Machine  

 

 

Figure 2.48 Layers of Three Different Texture Set List of Mold Machine 

There you can turn on/off any of the UDIM tiles for the help of the texturing.  
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I have given screenshots of  three different UDIM tiles for understand how the texturing work 

in substance painter if you import any model with multiple UDIM tiles. 

 

2.3.7 Toy Cars : 

Texturing process of the car was a little difficult because as it is the main prop for the story so 

it’s needed to be perfect. It was difficult to find the solution for creating different reflection 

maps for the body of the car and the stickers on the body. It was exported from Maya with 

single UDIM tiles so I used the polygon texture method sometimes to texture small parts of 

the car.  

 

 

Figure 2.49 Toy Car Texturing in Substance Painter 

 

2.3.8 Pliers : 

At first the .fbx format file of pliers was imported in Substance Painter. Press File > New 

>Select the fbx file >then press ok. It will import the smooth mesh of pliers exported from 

Autodesk Maya . 

After this I baked all the texture sets with a resolution of 2k.I baked the world space normal 

map, ambient occlusion map, curvature map and the position map. All these maps will make 

the texture process easier. 
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Figure 2.50 Pliers Texturing in Substance Painter 

 

As you can see, I have used some smart material from the material shelf and also created some 

fill layers to add more details in the models. That logo of “VISE-GRIP” was first created in 

photoshop then used as e height map in substance painter for making the bump. 

 

 

Figure 2.51 Pliers Render Image with Texture in Autodesk Maya 
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2.3.9 School Building : 

The school model was so big that taking its UV as UDIM texture set was tough. So I textured 

it with photoshop with a seamless brick texture. I had to create a bump map from that texture 

so that I can give some bump in my school walls. 

 

 

Figure 2.52 Bump Map Creating for Bricks in Adobe Photoshop 

 

 

Figure 2.53 School Building Rendered Image in Autodesk Maya 
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2.4 Lighting 

 

The lighting of all the scenes in this project was done with both default Autodesk Maya Lights 

and Arnold Lights. Solid Angle’s “Arnold Render”[14] was the render engine which we used 

for our whole project. For specific scenes we used different kinds of lights according to the 

mood needed for the story. From Arnold we used Sky dome Light, Area Light, Mesh Light 

and from Maya, we used Directional Light and Spot Light. I’ll describe the parameters of light 

for every scene in our project. 

 

In the first scene, there are three shots. One is the extreme close shot of the toy car; the second 

shot is the long shot and the last one is the mid shot of our main character Shanto. As it was a 

day time shot, so I have used a Maya default Directional Light and an Arnold Sky dome Light. 

You can find the Maya Directional Light under Menus >Create >Lights >Directional Light. 

It’s a default Maya light which is available in every version of Autodesk Maya. 

 

 

Figure 2.54 Directional Light Parameters of First Scene  

 

The time of the shot was around 9 a.m., so I needed to create a light with a yellow tone. To 

change the color of the light, go to attribute editor by pressing Ctrl + E. Then go to directional 

light shape tab and change the color of the light to a bright yellow. The parameters of the 
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directional light for this scene is given below. The second source of light in the scene was the 

Arnold Sky dome Light. Which can be found under Menus >Arnold >Lights >Sky dome Light. 

This light has worked as a fill light for the scene. In the color attribute of the dome light, I have 

used a HDRI map of a bright day. To do this, you need to press Ctrl +E to open up attribute 

editor then go to aiSkydomeLightShape tab . Find the color option there and press the icon on 

the right side of color. Then select your HDRI map. The parameters of the sky dome light for 

the first scene is given below. 

 

 

Figure 2.55 Sky Dome Light Parameters of First Scene 

 

In the second scene, there was only one shot. It was also an outdoor shot so the light I have 

used was the same as the previous scene. 

The third scene was an indoor scene with three different shot so the lights were different from 

the last two scenes. One close shot and two mid shots. As it was an indoor shot with the 

windows so I needed to create both outdoor and indoor lights to make the scene realistic. 

 



45 
©Daffodil International University 

 

 

Figure 2.56 Spot Light Parameters of Classroom Scene (Outdoor) 

 

There are total five lights in this scene. One directional light, one spot light, one sky dome 

light and two area light. I have already discussed about Maya default Directional Light and 

Sky dome light. The Spotlight is also a Maya default which can be found in Menus> Create> 

Lights> Spot Light. 

 

Then comes the Area Lights which is an Arnold Light. It was needed for the indoor 

environment. This light can be found in Menus> Arnold> Lights>Area Light. 
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Figure 2.57 Area Light Parameters of Classroom Scene (Indoor) 

 

The fourth scene was the starting of the factory scene which also have a lot of lights. In total 

there are six lights for the main factory scene. One Spot Light, four Area Lights and one Sky 

dome light. Different Area Lights were needed because there were four spots for lights to come 

in .One window, one door and two transparent roof spots. 

 

 

Figure 2.58 Spot Light Parameters of Factory Scene (Indoor) 
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As the demand of the story this scene needed to have a yellow tone because the bulb you see 

is an old-fashioned yellow bulb. The four other area light had all different parameters 

according to the needs of the scene. 

 

 

Figure 2.59 Area Light Parameters of Factory Scene 

 

The last scene is in the store room of the factory. The lighting was almost the same as the 

previous scene but there were some changes. As in the last scene the camera had a window in 

view, so I had to create a direction light to mimic the sun light. It was not easy to combine the 

low light of the factory indoor and the sun light of outdoor. 
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Figure 2.60 Combination of Indoor and Outdoor Lights 

 

At the end of the lighting part I would like to show the final results of the lights I have described 

earlier. These are the final rendered file in Autodesk Maya with Arnold Renderer. All the 

images given below have the raw color produced by the Renderer. 

 

 

Figure 2.61 First Scene Final Rendered Image  
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This is the raw render output of the long shot from the first scene and second scene. I have 

used one Maya Directional Light and one Sky dome Light for these two scenes. 

 

 

Figure 2.62 Second Scene Final Rendered Image 

Volumetric fog was added in the rendered image below from Maya’s default Environment.  

 

 

Figure 2.63 Classroom Final Rendered Image 
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This picture in the figure 2.63 was the shot from third scene which is in the classroom. There 

are total five light sources to illuminate the scene. And the picture below is from the factory 

scene. It has a total of six lights which I have already described. 

 

 

Figure 2.64 Main Factory Final Rendered Image 

 

 

Figure 2.65 Factory Storage Room Final Rendered Image 
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This picture in the top is the shot from the storage room of the factory. It has three light sources. 

And the picture below is from the last shot of our animation short film. This have the 

combination of indoor and outdoor light set up. 

 

 

Figure 2.66 Last Scene Final Rendered Image 
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2.5 Render Settings : 

 

We have used Arnold Render Engine to render our short film. This is a render engine 

developed by the company “Solid Angle”. According to Wikipedia “Arnold is based on Monte 

Carlo Ray Tracing. Its engine is optimized to send billions of spatially incoherent rays 

throughout a scene. It often uses one level of diffuse interreflection so that light can bounce 

off of a wall or other object and indirectly illuminate a subject. For complex scenes such as 

the space station in Elysium, it makes heavy use of instancing. It uses the Open Shading 

Language to define the materials and textures.”[15] 

To control the rendered resolution the “Arnold Sampling”[16] must be controlled  precisely. 

For each of our scene we used different sample rate according to our need. 

 

 

Figure 2.67 Default Arnold Sampling Parameters  

For our first scene to render we used our customized render sampling according to our need 

and available time because render time depends on render sampling. 

https://en.wikipedia.org/wiki/Monte_Carlo_method
https://en.wikipedia.org/wiki/Monte_Carlo_method
https://en.wikipedia.org/wiki/Open_Shading_Language
https://en.wikipedia.org/wiki/Open_Shading_Language
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Figure 2.68 Final Render Setup and Sampling Parameters 

 

The export format for our render output was set to exr (.exr) in order to preserve the best 

quality and information. We have used total 7 “AOVs” [17] for control in the post production. 

 

Figure 2.69 Final AOVs for all Scenes 

These AOVs means there will be different 7 different passes, all together will make the beauty 

layer. 
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CHAPTER 3 

Limitations and Challenges 

3.1 Limitations: 

A lot of intangible limitations were faced while working on this project. These limitations 

affected the output of our project in one way or another. Some of these are discussed below. 

 The most intangible limitation was the lack of experience. There were some experiences in 

all the steps in this process but the proper pipeline was never followed. Also, the scope of skill 

implementation was also limited. When it came to such a big project with a proper pipeline 

was to be followed, we fell short on experience we fell short on experience which affected 

time management and finding solutions to problems faced. 

3D animation is a form of art which combines a lot of other forms of art. For initiating a project 

like this a lot of things from the artistic angle needs to be considered. Such as the color palette 

of the film, the looks of the characters, forms of different models, postures sense, perspective 

sense, a sense of composition etc. For this reason, a strong hold on fine arts category is much 

needed. Unfortunately, this skill is inadequate. Being a student work there were no fixed 

budget for this project. 
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3.2 Challenges: 

As this is a group project it was important that all the members work together with close 

proximity so that whenever any member faces a problem they can reach out to other members. 

This makes problem solving much easier and obtaining approval faster. Living in different 

homes at first there were no fixed spot where all four members could work together but 

eventually a room was rented and the challenge was met. 

All the software used for 3D animation and rendering require high configuration computers. 

In this case the higher the configuration the better the quality. But for our average quality 

computers we faced a lot of challenges to work with. The software kept crashing or getting 

stuck. Sometimes they became slow and could not read the commands and execute them 

properly. Sometimes files would take several minutes to even open up. These kinds of 

problems wasted a lot of time which would not have been an issue if there were better quality 

computers available. 

 Computers with higher configuration can decrease render time exponentially. Render time a 

big factor when it comes to producing any computer graphics. Keeping computer limitation 

on mind sufficient time slot needed to be allocated for the rendering segment. 

 In order to create the desired outputs a few new software and commands from known software 

were needed to be learnt in a very short time. As the knowledge of these software were limited 

so problem solving became a big issue. 
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CHAPTER 4 

Some Problems and Solutions  

UV Unfolding :The default unfold option sometimes does not work properly while unfolding 

the shells. For eliminating this problem sometimes, the default unfold method needed to set to 

legacy in the options box beside unfold in the UV toolkit. 

Rigging :As the project was done mainly in Maya 2018.6, the plug in we were using for 

rigging did not work properly. The skeleton build process could not be completed. To solve 

this problem the rigging was done Maya 2017[14]. 

Maya Mash :The trees in this film were made with Maya Mash. While doing this sometimes 

the leaves were not attached to the surface of the mesh they were input on. They would scatter 

by offsetting around the mesh. It was then figured out that if the main leaf was freeze 

transformed at 0, 0, 0 point of the gridline then it would work properly. 

Leaf Texturing :The leaves were made with a PNG file on a plane to make the trees low poly. 

But the leaves were not rendering transparent. By assigning maps in the parameters of the 

plane this problem was fixed.  

Arnold Stand Ins :Some heavy objects were made proxy by the Arnold Stand In options to 

the scenes would be less heavy. But these Stand Ins did not receive texture files when 

transferred to a different computer. Several methods were tried but the result was the same. 

We couldn’t solve this problem entirely but it was decided the scene with Stand Ins will only 

be rendered with computer they were made in. 

Source Image :While rendering the files were distributed to a number of computers. But some 

of the models did not receive textures directly from source image. So, they rendered without 

texture. This caused us system loss and a lot of rendered files were discarded. So, every file 

needed to be checked thoroughly before rendering in every single computer. This added to the 

total time allotted for rendering and created a time crunch. 

Texture loading failed :As there were a lot of heavy models in most of the scenes and all of 

them had high resolution textures, the GPUs in our computer failed to load them eventually 
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causing software crash sometimes. So, texture mode was turned off while working on heavy 

scenes. 

Viewport loading failed :Some of the scenes were so heavy that the computers with lower 

amount of RAM failed to load them on the viewport. To temporarily fix this problem extra 

RAM was borrowed and added to the computers. 

Storage problem :The entire project was approximately 1.5 TB in size. Some of the files also 

needed back up. To meet this challenge portable hard drives were managed. 

Render time optimization : Each frame required 20 minutes to render on average. In this rate 

the total rendering time would exceed 2 months. We could not afford this much time so 

rendering was distributed to 29 Computers in total. This reduced render time exponentially 

leading us to finishing our project in time. Some of the scenes were also rendered in alpha 

channel where background could be a still image. This also reduce render time. 

Manual Subdivision causes PC freeze :For giving a high poly look to the character hairs 

more subdivision was needed to be added. But by adding more subdivision the file size 

increasing a lot causing software crash. So instead of increasing subdivisions physically on the 

model, the iterations were increased in rendering within the Arnold tab which gave the model 

the desired high poly look without actually adding more subdivisions. 
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CHAPTER 5 

Conclusion  

Due to the weakness of the law and mass poverty, the number of child laborers are increasing 

day by day in our society. These children are subjected to harsh and dangerous working 

conditions, even in some cases physical abuse and sexual harassment. 

This animated short film is a small attempt to expose all these inconsistencies of society with 

child labor. 

While doing this project we had some unique experiences. We learned a lot of in-depth 

knowledge about 3D animation pipeline. This project gave us the opportunity to learn a few 

new software and more about the software’s we were already familiar with. 

We faced various issues while working on this project but solved most of them by consulting 

and researching together. Although there are some problems, we were unable to solve but we 

are keen to learn about them in the future. 
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