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ABSTRACT 
 

Good representation of a product for selling is very significant for growth in business. And 

showing the product on a website for convincing a consumer to buy is very challenging in 

this modern era of online-based marketplaces. In the earlier day’s web-developers would 

use product images or promotional videos in websites for digital marketing. They still do 

this now. But time and technology are changing rapidly and people want to interact with a 

product before they buy it. Let’s say, before buying a furniture if we could measure the 

dimensions through putting the furniture in the room space virtually to check whether it 

fits or not, it would be a very smart use of technology. Now, it is really possible through 

only a smartphone and AR Technology. So, in that sense, we can make website-compatible 

3D models and apply AR technology on them. My aim is to test a complete and proper 

pipeline for AR-compatible 3D model production. 

 

There are several steps to create a website-compatible 3D model. Models can be made 

using Autodesk Maya, textured using Substance Painter, website-compatible GLB/ GLTF 

file format creation using Blender 3D. Compress and publish using online GLB packer; 

like (http://viewer.seekxr.com/) and (https://glb-packer.glitch.me/). We can use Marmoset 

Toolbag software for video renders of the products. 

 

Web-based AR technology for product visualization is a blessing for both a seller and a 

customer. A seller can sell more products online and a consumer can be more confident 

about purchasing anything from online. 
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CHAPTER 1 

Introduction 
 

There are two types of 3D models; Organic and Hard-surface. So, for understanding the 

procedure to build up their shapes and structure we need to choose which software is the 

best solution for the production. For an Organic model creation, sculpting is a better 

solution in case of easy production than poly-modeling. And there are dedicated sculpting 

software like ZBrush, Autodesk Mudbox which are industry standard and more user-

friendly software. On the other hand, Hard-surface modeling requires poly-modeling 

technique. And for poly-modeling, there are various software like Autodesk Maya, 3DS 

Max, Blender 3D, Modo and so on. So, the very fast step for starting modeling, we choose 

the software we needed and book a monthly or yearly subscription according to our 

demand and sometimes we purchase them. 

 

For a Hard-surface model, after modeling, we directly go to the texturing process in 

Substance painter and then we convert and compress the model. We use Blender 3D for 

website-compatible GLB/ GLTF file format creation and some online compressing 

solutions. But, for an Organic model, after sculpting we need to Retopo the model for 

maintaining a good topology with reasonable file size. We use the quad draw feature of 

Autodesk Maya for the Retopo process. After that, we go to texturing, convert and 

compress steps sequentially. 

 

This production pipeline is a step by step lengthy process. Following the proper procedure 

will make sure a good looking and highly optimized AR-compatible 3D model.
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CHAPTER 2 

Literature Review 
 

This chapter will be discussing the thesis on the different journals and books about Web-

based AR technology and production pipeline. Here are lots of theories given by many 

researchers. Analyzing all those theories and pick up the main points from those, and 

finally we will take a particular theory and work on that. 

 

2.1 Augmented Reality History 

In 1968, a Harvard faculty member and computer scientist by the name of Ivan Joan 

Sutherland fictitious what he called the Sword of Damocles. He fictitious this as an initial 

form of augmented reality device along with his student, Bob Sproull. 

 

The Sword of Damocles featured a head-mounted display that adorned from the ceiling. 

The users would experience computer graphics, that could make them feel as if they were 

in an alternate reality. This technology can be thought-about nearer to virtual reality than 

augmented reality. 

 

One of succeeding massive developments was done on augmented reality in 1974 by 

Myron Krueger. The project was known as Videoplace, which joined a projection frame 

and camcorders that created the screen shadows. This arrangement could make the clients 

feel as though they were in an intelligent situation.  

 

In 1990, a Boeing scientist named Tom Caudell begat the expression "Augmented 

Reality".  

 

In 1992, Louis Rosenburg from the USAF Armstrong's exploration lab made the absolute 

first genuine operational enlarged reality framework, Virtual Fixtures. A robotic system 

places data on top of the workers' work environment to assist efficiently. This technique 

could be thought of like the early version of what most AR systems presently do these 

days. 
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In 1994, the primary theater production to utilize augmented reality that made. “Dancing 

in Cyberspace” bestowed acrobats dancing in and around virtual objects on stage as a bit 

of art and was produced by Julie Martin. 

 

 
Figure 2.1.1 Ivan Sutherland with a Head-mounted 3D Display. 

 

In 1998, Sportsvision used the first and Ten-line automatic data processing system. This 

technique showed the original virtual yellow first-down marker throughout a live NFL 

game. A variation of this virtual first-down marker is currently a norm altogether televised 

soccer games these days and is a massive part of augmented reality history. 

 

In 1999, NASA used a hybrid artificial vision system that integrated augmented reality in 

their X-38 space vehicle. The augmented reality technology was used to facilitate improve 

navigation throughout their test flights. 

 

A significant progression inside the augmented reality innovation occurred in 2000 once 

Hirokazu Kato from the Nara Institute of Science and Technology in Japan made a 

software known as ARToolKit. Through this software, one may capture real-world actions 

and mix it with interactions of virtual objects. 
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Through the utilization of a camera and therefore the web, users can experience this 

augmented reality. Like several of those inventions from the past, this heavily influenced 

what we have a tendency to experience these days altogether flash-based augmented reality 

apps. 

 

In 2003, the NFL used the popular Skycam, that was used for aerial views of the sector to 

insert the virtual first-down marker. 

 

In 2009, Esquire magazine, together with Robert Downey Jnr, used augmented reality in 

their medium. By exploitation their software on one’s computer to scan the barcode on the 

magazine, the readers could experience augmented reality content. 

 

In this same year, ARToolKit made augmented reality out there to web browsers. 

 

Augmented reality has returned an extended method since its early conception, and 

therefore the advancements within the past 5 years are even splendid. 

 

 
Figure 2.1.2 Google Glass in AR Factory. 
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2.2 Recent Developments on AR 

In 2013, Volkswagen used augmented reality as their automobile manuals. the use of the 

MARTA app through the iPad would facilitate users read the internal workings of the 

vehicle therefore the service mechanics apprehend what they're handling. 

 

The MARTA application can even show sequent directions to assist mechanics with the 

projects they're performing on. It would even facilitate with commutation components. It 

would even be as specific as that direction the components ought to be facing. The 

MARTA app would be used for a lot of cosmetic projects similarly, together with seeing 

how completely different color paint jobs would look on our vehicle. 

 

In 2014, Google Glass was discovered and was been created out there for customers. The 

Google Glass wasn’t as victorious as developers hoped it'd be, however it did show the 

potential of what wearable augmented reality can be. The second iteration already looks 

to be splendid and a lot of helpful. 

 

Instead of victimization the Glass to scroll through social media and using apps; factory 

employees are using the technology to assist with their everyday work. It helps walk the 

employees through their daily tasks and be a lot of productive and economical. 

 

In 2016, Microsoft introduced consequent iteration of wearable augmented reality. The 

HoloLens appears to be everything that the Google glass needed to be, however not at all 

as discreet and wearable in existence and is beyond question more expensive. The 

technology advancement between the two is unquestionable, however the value range of 

$3000 and $5000 are out of most people’s budgets. 

 

Augmented reality has conjointly infiltrated the gaming world similarly. The Nintendo 

3DS comes with AR Cards that trigger integrated AR games. similar to Pokémon Go, users 

can see their favorite characters within the same space as them. 
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Figure 2.2.1 Pokémon Go Augmented Reality. 

 

Snapchat has even created its own AR games that are engineered right into the app. The 

utilization of facial gestures controls all of our movements in every game. 

 

 
Figure 2.2.2 AI Facial Recognition. 



©Daffodil International University 7 

 

 

 
Figure 2.2.3 AR Snapchat Filter. 

 

2.3 Web-based Augmented Reality for eCommerce 

Augmented reality is all over lately. It has been around for a couple of years currently 

within the variety of face filters on Snapchat, Facebook, etc. and app-based experiences 

have popped up from IKEA, Warby Parker, and others that are before the curve in giving 

their customers the simplest online shopping experience attainable. many have puzzled if 

augmented reality would have an even bigger impact than its forerunner of virtual reality, 

that to several within the investment and the effect of the tech globe on living standards 

has been severe. Because it seems, AR has a fairly major impact, and its reach is already 

over and over that of VR due to the innovations in smartphones that billions of individuals 

have already got in their pockets. 

 

Studies associated with the impact of AR on eCommerce are commencing to surface, and 

also the numbers are astounding. 30%+ increase in conversion, reduced returns, less 

inequality between client expectations and accrued client trust within the brand. AR is 

commencing to approach, in several cases, the effectiveness of getting somebody walk 

into a physical store, however while not all the prices and headache of maintaining a retail 

location that looks doomed to fail during this age of retail locations closing at the very best 

rate ever. 

 

So, if AR works therefore well, how does one get started with it? it's going to seem to be 



©Daffodil International University 8 

 

 

a frightening and costly task (and it will be if we approach it incorrectly), however 

hopefully, the subsequent ideas will act as a guide to induce us on the proper path. 

 

2.3.1 3D Model Creation 

If at any time in our AR experience, we wish customers to be ready to view our 

merchandise in their house, digital twins, or 3D models of our merchandise are needed. 

Several corporations have already been doing this for years, and that they are definitely 

prior the sport. Moving forward, these 3D models ought to be a typical in our product 

imagination process. Rather like we see unbelievable CGI in movies with models that look 

thus real we cannot tell the difference; it's currently doable to make unimaginable 3D 

models of all of our products. There are three primary ways that to create this happen: (in 

order of least valuable to most expensive) 

 

1. Use the design files that were used to manufacture our product. These are probably some 

kind of CAD file that can be exported into several 3D formats which will be utilized in 

AR experiences. The best AR suppliers are going to be able to use these outputs and 

convert them into usable content with very little to no effort. Not all firms have access to 

those files, particularly if we’re resellers, however there are alternative ways in which to 

make this happen. 

 

2. 3D model creation is an art that some will do unbelievably well. 3D modeler like me, will 

inspect an image of a product and then create a model from the ground up. This option is 

the most popular straight away due to the associated prices. Most models can be created 

for $150-350, looking on the quality and complexity of the model.  
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Figure 2.3.1.1 3D Model Creation for AR. 

 

3. 3D scanning may be a newer technology that includes a long way to travel before it's cheap 

enough and widely obtainable enough to be used at a major scale. There are incredible 

scanners which can be purchased for roughly $25k each that produces nice results. They're 

not plug and play devices, though, and need hardware and software package training. The 

usual price of 3D scanning an object is $1000 (this would be for something sort of a table). 

Cheaper choices are out there, however they are not superb nevertheless. There are many 

firms out there, together with Qlone, that are specializing in building tools that enable our 

phone to become the scanner. They're mostly limited to small objects at now, however as 

phone manufacturers embrace additional depth sensors and better cameras, this may 

become better over time.  

 

2.3.2 Useful Features of Augmented Reality 

There are numerous things that can be done with augmented reality content, thus defining 

this early within the process can assist us verify wherever we'll be able to publish it, what 

proportion it'll cost, and what team we will need to get there. Of course, begin with the end 

goal in mind. What does one need the consumer to do? Does one have furniture that we 

need individuals to be able to see in their space? Do one need individuals to be able to try 

on a hat or glasses? Does one need it to merely be something fun and shareable to surprise 

and delight their audience? Does one need social reach? Or are we just attempting to extend 
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conversion rates? 

 

Once we have got this nailed down, we'll be able to begin to differentiate what capabilities 

platforms have. Let’s see couple of options:  

 

Face-scanning 

Snapchat lenses are around for some time now, so most people are familiar with face 

filters. Since face-scanning has been around for some time, a few stages can do this past 

Snapchat, just as Instagram and Facebook. the web is even capable of doing this currently. 

This becomes very powerful as a result of it can be integrated directly onto the product 

page on our website, keeping the user engaged within the traditional eCommerce 

experience they are known to. 

 

True-to-size and plane tracking 

Cell phone cameras are presently quite strong and can detect the distance from the device 

between the floors and walls. Due to this measurement, product can be displayed true-to-

size through the camera view. For furniture, this can be a requirement. Will the table fit? 

What is going to this tub look like on my deck? Without accurate plane tracking, this is 

not possible. AR is concerning way more than just showing a 3D model in a camera view. 

It must be concerning permitting the client to see what the merchandise can appear as if in 

their life. Thanks to ARKit and ARCore (technologies developed by Apple and Google 

for iOS and android respectively), apps will now track aircraft fairly well. Recently, Apple 

launched technology permitting iOS users to possess access to this technology directly on 

the web. Seek is another renowned AR solution company and they designed a cross-

platform solution that brings this functionality to android on the web also. 

 

Target or marker tracking 

Target tracking ties expertise to a particular image or anchor within the real world. 

Snapchat, for instance, lately enabled the Lebron James Snapchat lens, which requires 

users to be at a footlocker place, open Snapchat and tap the camera at a mural on the wall. 

This could be an excellent experience if we would like users to do something in the store. 

Most target tracking experiences happen inside an app, however Seek's web-based AR 

technology will do that on the web also. 
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Interactivity 

To play a game, spin the object, resize it, alter the color, etc., do the clients need that? To 

go through every detail concerning this here, would double the size of this Report, however 

here are the fundamentals. Web-based AR remains at the point where basic product 

viewing (typically one product at a time) is that the only thing possible if we would like 

true-to-size tracking. Of course, this may improve over time. If we ignore true-to-size, then 

a lot of interactions can be done on the web. If we have got a target tracking, close to 

something is possible from an interactivity perspective. inside a custom app, the sky is the 

limit. Facebook, Snapchat, and Instagram have very specific functions that we simply can 

utilize within experience design, and we'll be able to learn these by going to their specific 

studios to learn more. 

 

Sound 

Sound is an incredibly powerful tool for all media (where appropriate). Simply if we try 

to watch Lord of the Rings or Star Wars without sound. It would be pretty boring. Turn up 

the volume, and we’re sucked into another universe and it tugs at our emotions. Once used 

properly, sound will add a further part of reality to form the user believe what their eyes 

are seeing. If Spiderman appears to be standing in front of us on our camera, can there be 

sound to add to this experience? Some AR experiences on the web may have sound. Apps 

actually can. Sound is not necessary for eCommerce in most cases, except for the 

entertainment industry and alternative related use cases, sound will take the experience to 

the next level. 

 

2.3.3 Ways to Access the Contents 

This, in my opinion, is that the most vital element to consider once starting with augmented 

reality. How are people about to get to this content? What percentage barriers are we about 

to place in between our audience and therefore the content or between the content and 

therefore the product? What demographics can see our content based on each location? are 

we about to place this on a social platform? A brand-specific app? Directly on our website? 

 

The next obvious question is "where do individuals buy our merchandise from?" If we sell 

most of our products on walmart.com, then understand if walmart.com features a solution 

for AR directly on their website. or even in their app? If we sell most of our merchandise 
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directly on our website, then that is wherever this AR practicality should go. 

Until recently, it had been only doable to make AR capabilities into an app. a really 

common furniture website has shared some attention-grabbing statistics with U.S.A. In 

their own proprietary app, this brand has spent many bucks on their augmented reality 

characteristics (which they need to handle for both iOS and Android) and that they see 

unbelievable increase in conversion from this AR. Average mobile conversion without AR 

is about 3.5%. With AR, it's 11%. Let’s pause for an instant to digest that. 3.5%-->11% 

and therefore the only distinction is AR. Huge impact. However, there is a downside. Only 

5-hitter of their total traffic uses their app! Many dollars and unimaginable technology 

engineered, however 95th of their audience is missing out. 

 

Now, augmented reality on the web is feasible. Through, it's doable on iOS and android 

with true-to-size accuracy. 2 very important points are notable here: 

 

1. Once AR is accessible directly through the website a much larger audience is reached. 

individuals simply don't desire to download brand apps. Some will, however most will not. 

2. Once AR is accessible directly on the merchandise page, there's no major change in 

behavior from the customer. Customers are already conversant in clicking on an image or 

a video, therefore if the AR practicality may be embedded directly into an image on the 

website, then the client does not have to change their behavior to access this powerful 

product visualization.  

 

2.3.4 Steps to Follow 

Most brands haven't got the budget to take on AR by themselves. For this reason, several 

corporations can prefer to find a partner to deliver this service. A lot of developers around 

the world have access to repositories, tutorials, and comparatively straightforward tools 

that may be used to produce seemingly complicated AR demos. This makes it laborious to 

tell apart who really is aware of what they're doing and who will deliver a scalable solution. 

This is where the details are really important. Here are a number of points I might address 

once evaluating a possible solution: 

 

Ease of Installation 

How many hours can our tech team have to spend adding code to our website? Do they 
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need to do separate installations for each single item? distinctive installations per platform? 

how can it be maintained? 

 

Content Management 

If we have got 100+ product, how can we manage this content? Is there a straightforward 

interface that permits us to manage these files and improve upon them whenever 

necessary? 

 

Content Creation 

Can the corporate handle content creation? Or can we’ve got to search out a separate 

vendor for this piece? Keeping everything under one partner can make it easier for 

everyone involved. Content creation is an art; however, it's more than just making it look 

pretty. Files got to be optimized for mobile viewing and formats got to be compatible. This 

can be tougher than it's going to sound. Having a partner that may deliver the A to Z 

solution finally ends up saving time and headache. 

 

Content Conversion 

If a brand already has 3D models of their product, the chances of them being AR prepared 

are comparatively low. There are very specific formats that work well for mobile and a 

few that are simply terrible. We tend to found a solution a few month ago that presupposed 

to be the "best AR solution out there" and we’re using a file format known as OBJ. This 

can be a bloated-on format that's terrible for mobile performance. Remember to the times 

of BMPs for pictures and compare that to these days with JPGs and PNGs. The distinction 

is night and day for performance. This can be a fancy issue, and since of the fast-changing 

AR market, there are in all probability formats we still haven't seen which will jump onto 

the scene and complicate more. 

 

Content Optimization 

Is that the content optimized for mobile? Several 3D models are stunning, however they're 

30 MB or even 500 MB. How a user about to feel once they have to sit there waiting to 

transfer an oversized file in order to look at a product? Downsizing content to below 5 MB 

is an art as well as a complicated procedure that few have mastered.  

Content Deployment 
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How easy is it to place new content on the website? Will the content be deployed to 

multiple platforms or devices? Will it be shared on Facebook? Are we going to share on 

Snapchat? etc. 

 

Cross-platform/ Device Capabilities 

Will this work on just iOS? Just Android? Can it work on future devices (Addressed more 

within the next section)? 

 

Ease of Use for the End User 

Is that the interface clean, simple, and intuitive? Will the user have to be compelled to 

download an app? Do they need to learn a replacement platform to check our content? 

 

Deploy and Evaluate 

Some experiences have such a big amount of specific conditions that have to be compelled 

to be perfectly met for the experience to show out that half the time, it simply does not 

work! Check what we're doing and make sure that the experience will not frustrate our 

client, however that it'll drive them to need to associate more along with our brand. The 

details matter, and if the incorrect path is chosen early on, it can be overpriced and time-

consuming to fix later. 
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CHAPTER 3 

Project Workflow 
 

This chapter will be discussing the uses of different software and workflow of how to 

create a 3D product model for the web. In this part, I will be modeling and texturing few 

product models. I will do this in a step by step process and use Autodesk Maya, Substance 

Painter, Adobe Photoshop and Blender 3d for the production. 

 

3.1 Modeling and Texturing a Leather Couch 

We must follow the requirements written below to build the models. 

 

1. Build the model with PBR materials. 

2. Textures should be no larger than 2k and should be in JPG when transparency is not 

required, otherwise, use PNG. 

3. Do not include textures that are unnecessary; for example, not all models need ambient 

occlusion or normal maps. 

4. It is preferred that separate materials and textures be used for different parts of the model 

(for example, the wooden part of a chair would be a separate material than the fabric). 

5. There is a polygon count limit of maximum of 30000 vertices. 

6. The final model needs to use meters as the unit. 

7. The models should not require double-sided rendering to look good. 

8. Export the model to GLB format. The final file size (including textures) should be under 

5 MB. 

9. The diffuse texture needs to not tile. 

10. Bake ambient occlusion for the fabric material. It should be a single-channel (black and 

white) jpg image. 

 

Step 1: We need to follow the references and proper dimensions to start building the 

furniture base structure. For this model, the dimensions are: 

 
Width   36 In   Arm Height  24 In 
Depth   35 In    Seat Height  18 In 
Height   42 In    Seat Depth  21 In 
Inside Width  21 In 
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And the reference images are:

 
Figure 3.1.1 Couch References. 

 

Step 2: Go to Windows> Settings/Preferences> Preferences> Settings and set the Unit to 

Inch. 

 

 
Figure 3.1.2 Unit Setup. 
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Step 3: Go to View> Image Plane> Import Image and import both Front and Side views 

reference images. Go to Create> Polygonal Primitives> Cube and create a cube with Width 

= 36 Inches, Height = 42 Inches and Depth = 35 Inches. Add two more cubes for defining 

Seat Width = 21 Inches, Seat Height = 18 Inches, Seat Depth = 21 Inches and Arm Height 

= 24 Inches. And add them to a layer as Templated. 

 

 
Figure 3.1.3 Reference Cube for Dimension. 

 

 
Figure 3.1.4 Image Plane Setup for Reference. 
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Step 4: Create all the components using poly-modeling technique one by one and Combine 

components according to the material count. For example, in this model there are 3 

different materials would be assigned (Gloss, Leather and Wood). So, the component 

amount should be 3. Vertex Count should be less than 30,000. The edge seems should be 

created using below settings: 

 

 
Figure 3.1.5 Structure Build-up with Poly-modeling. 

 

 
Figure 3.1.6 Seam Piping Making. 
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Figure 3.1.7 Material According to Mesh Count. 

 

Step 5: Check and Delete UV Sets, if there are more than one UV Sets by going UV> UV 

Set Editor for every component. As well as check and Delete all the Vertex Color Sets for 

every component by going Mesh Display> Color Set Editor. 

 

 
Figure 3.1.8 Checking UV Set and Vertex Color. 
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Step 6: UV Unwrap all components one by one. Select seem edges and press SHIFT+X 

on UV Editor window to cut selected edges. Select all UV Shells and press CTRL+U to 

unwrap and press SHIFT + RIGHT CLICK> Orient Shells. Set Shell Padding and Tile 

Padding to 1 pixel and press CTRL+L to Layout UVs. 

 

 
Figure 3.1.9 UV Layout Settings. 

 

 
Figure 3.1.10 UV Unwrap and Layout. 
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Step 7: Go to Windows> Settings/Preferences> Preferences> Settings and set the Unit to 

meter. (i.e.: Substance Painter only supports meter as unit.) Select all the components and 

Export the model as (.fbx) format. 

 

 
Figure 3.1.11 Export Unit Setup. 

 

Step 8: Open the (.fbx) File on Substance Painter. Go to Texture Set Settings and Bake 

Mesh Maps at 2048 resolution and Bake all texture sets. 

 

 
Figure 3.1.12 Texture Set Bake. 
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Step 9: Apply Leather Stylized smart material to the Part1, Aluminium Anodized Red 

smart material to Part2 and Wood Walnut material to Part3 Layer stack. 

 

 
Figure 3.1.13 Texturing in Substance Painter. 

 

Step 10: Go to File> Export Textures> Configuration and create a new preset for Blender 

3D Export and Export textures in (.jpeg) file format using this preset. 

 

 
Figure 3.1.14 Export Textures Settings. 
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Step 11: Import (.fbx) file on Blender 3D and assign all the textures correctly and export 

as (.glb) file format. 

 

 
Figure 3.1.15 Texture Node Setup in Blender3D. 

 

Finally, we get a website-compatible Leather Couch model in GLB file format that we can 

upload and view online without any problem. 
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3.2 Modeling and Texturing a Smart TV 

Step 1: Change the measurement unit into Meter. I will go to Windows> 

Settings/Preferences> Preferences> Settings and change the unit. 

 

 
Figure 3.2.1 Unit Setup. 

  

Step 2: Go to View> Image Plane> Import Image and import Front, Side, Top and Back 

views reference images. Go to Create> Polygonal Primitives> Cube and create a cube with 

Width = 57.0625 Inches, Height = 35.5625 Inches and Depth = 0.172 Inches. 

 

 
Figure 3.2.2 Image Plane Setup. 
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Step 3: Go to Attribute Editor and change image plane display property for all image planes 

as looking through camera instead of in all views. 

 

 
Figure 3.2.3 Looking Through Specific Camera Setup. 

 

Step 4: Create corner edges smooth and try to match the curve using Bevel Edge (Ctrl + 

B). 

 

 
Figure 3.2.4 Matching the Model with the Reference. 
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Step 5: Create a Poly Cube and make the back-panel structure. 

 

 
Figure 3.2.5 Modeling Looking at the References. 

 

Step 6: Create a Poly Cube and resize to the back details, which we’ll use for Deference 

Boolean later. 

 

 
Figure 3.2.6 Modeling Looking at the References. 
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Step 7: Create an array of Poly Cubes by using Duplicate with Transform command (Shift 

+ D). 

 

 
Figure 3.2.7 Duplicating Array of Cubes for Boolean. 

 

Step 8: Create all the details of the back-panel for Deference Boolean process and Combine 

them. 

 

 
Figure 3.2.8 Preparing all the Details for Boolean. 
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Step 9: Selecting the back-panel mesh and mesh created for Boolean in order go to Mesh> 

Booleans> Deference. 

 

 
Figure 3.2.9 After Appling Boolean as Deference. 

 

Step 10: Go to Mesh> Cleanup an select Faces with more than 4 sides to cleanup n-gons 

of the back-panel. Create cavities for ports by using Mesh Tools> Multi-Cut and Extrude 

the faces inside. 

 

 
Figure 3.2.10 Mesh Cleanup After Appling Boolean. 
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Step 11: Create all the ports and buttons. 

 

 
Figure 3.2.11 Creating Ports and Buttons. 

 

Step 12: Try to stick with minimal mesh count and apply one material for one mesh. UV 

Unwrap all the meshes (Ctrl + U), Shift + Right Click on UV Editor and select Orient 

Shells. Layout UVs (Ctrl + L) keeping Shell Padding and Tile Padding 2 Pixels. Check for 

multiple texture set and any unwanted vertex color and File> Export Selection at Meters 

as Unit in FBX file format. 

 

 
Figure 3.2.12 UV Unwrap, Layout, Checking Texture Sets, Vertex Color and Material Count. 
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Step 13: Import FBX to Blender3D and selecting meshes one by one apply Object Data> 

Normals> Auto Smooth and Export FBX again. 

 

 
Figure 3.2.13 Apply Auto Smooth in Blender3D. 

 

Step 14: Create new Substance file using the TV_B3D.fbx file and Bake Mesh Maps for 

Back_Tex and Display_Tex at 1024 and Leg_Tex and Port_Tex at 512 resolution. Apply 

materials and textures according to the references. 

 

 
Figure 3.2.14 Baking and Texturing in Substance Painter. 
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Step 15: Export as GLB file according to the settings below. 

 

 
Figure 3.2.15 Texture Export Settings. 

 

 
Figure 3.2.16 Final Output (Front). 
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Figure 3.2.17 Final Output (Back). 

 

And This is the final output of the Smart TV Model. 
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3.3 Re-Modeling and Texturing a Coffee Machine 

Inspection 1: This is an unoptimized coffee machine model which is 10.3 MB in size. 

 

 
Figure 3.3.1 Unoptimized Model. 

 

Inspection 2: The coffee beans on top of the model are made with poly mesh which is a 

major cause for its oversizing and if we use texture and normal map instead of poly mesh, 

we can reduce its size a lot. 

 

 
Figure 3.3.2 Coffee Bean Made in Mesh. 
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Inspection 3: There are interior details inside of the model which is unnecessary. So, we 

can get rid of that. 

 

 
Figure 3.3.3 Unnecessary Inner Details. 

 

Step 1: As it is a GLB format file; we can import it to Blender3D (Version: 2.8) and export 

as FBX file format. 

 

 
Figure 3.3.4 Converting GLB to FBX in Blender3D. 
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Figure 3.3.5 FBX Export Settings. 

 

Step 2: Import the FBX file to Maya, set up the unit to Meters. Try to modify the meshes, 

Delete the unnecessary component. If the mesh is unusable, start to re-model it and always 

try to keep the poly count low. Use the given model as size reference. 

 

 
Figure 3.3.6 Import FBX for Size Reference. 
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Step 3: Try to stick with minimal mesh count and apply one material for one mesh. UV 

Unwrap all the meshes (Ctrl + U), Shift + Right Click on UV Editor and select Orient 

Shells. Layout UVs (Ctrl + L) keeping Shell Padding and Tile Padding 2 Pixels. Check for 

multiple texture set and any unwanted vertex color and File> Export Selection at Meters 

as Unit in FBX file format. 

 

 
Figure 3.3.7 UV Unwrap, Layout, Checking Texture Sets, Vertex Color and Material Count. 

 

Step 4: Create new Substance file using the FBX file and Bake Mesh Maps for all texture 

sets at minimum 256x256 and maximum 1024x1024 resolution.  

 

 
Figure 3.3.8 Baking Texture Sets in Substance Painter. 
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Step 5: For glass create a New Shader Instance and going to Shader Settings, select pbr-

metal-rough-with-alpha-blending. Create Opacity channel from Texture Set Settings by 

pressing the + icon. And for light and display Create Emissive channel. 

 

 
Figure 3.3.9 pbr-metal-rough-with-alpha-blending for Glass. 

 

Step 6: Apply materials and textures according to the references. For coffee bean texturing 

create a fill layer and disabling all the channels except color, rough and height apply the 

seamless bean texture to both color and height and set the roughness to 0.55. 

 

 
Figure 3.3.10 Texturing in Substance Painter. 
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Step 7: Export as GLB file according to the settings below. 

 

 
Figure 3.3.11 GLB Export Setup. 

 

 
Figure 3.3.12 Final Output. 
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CHAPTER 4 

3D Model Optimization 
 

This chapter will be discussing 3D model optimization techniques. In this part, I will be 

making a car tire with high-poly mesh. Then, I will turn the high-poly details into depth-

map and apply it on to a low-poly model. I will do this in a step by step process and use 

Autodesk Maya, Substance Painter, Adobe Photoshop and Blender 3d for the production 

and also point out some online compressing solution. 

 

4.1 Baking High-poly Details on a Low-poly Mesh 

Step 1: Change the measurement unit into Meter. I will go to Windows> 

Settings/Preferences> Preferences> Settings and change the unit. 

 

 
Figure 4.1.1 Unit Setup. 
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Step 2: Go to View> Image Plane> Import Image and import tire pattern image on front 

view. 

 

 
Figure 4.1.2 Use Image Plane for Reference. 

 

Step 3: Go to Create> Polygon Primitives> Plane to create a plane, rotate it 90 degrees to 

X-axis and adjust its vertices to match the pattern. 

 

 
Figure 4.1.3 Pattern Creation Using Plane. 
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Step 4: Bridge all the edges, Extrude and make a repeatable pattern. 

 

 
Figure 4.1.4 Extrude from Pattern. 

 

Step 5: Go to Edit> Duplicate Special (Option box) and Instance 50 copies of the pattern 

along Y-axis at 0.022 unit. 

 

 
Figure 4.1.5 Duplicate Special Settings. 
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Step 6: Selecting all 50 patterns go to Mesh> Combine and selecting bottom vertices go to 

Edit Mesh> Merge and input 0.001 value. 

 

 
Figure 4.1.6 Array of Pattern. 

 

Step 7: Selecting the mesh apply Deform> Nonlinear> Bend and rotate the bend handle 90 

degrees to Y-axis and set the curvature to 182.64. Merge the vertices to make a complete 

circle. 

 

 
Figure 4.1.6 Using Bend Deformer. 
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Step 8: Complete the tire model by Extruding border edges to center. 

 

 
Figure 4.1.7 Making the Tire Shape. 

 

Step 9: Correct the curvature of the tire using Lattice. 

 

 
Figure 4.1.8 Using Lattice Deformer. 
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Step 10: Go to Modify> Convert> Smooth mesh preview to polygon and create a high-

poly tire. We can see the verts count by going to Display> Heads up display> Poly count 

and the verts count of the high-poly mesh is around 257856, which is a lot for a website-

compatibility. 

 

 
Figure 4.1.9 Convert Smooth Mesh Preview to Polygon. 

 

Step 11: Let’s make a very low-poly tire with same measurement and ignoring pattern 

details. The verts count of this model is 816, which is very efficient for the web. 

 

 
Figure 4.1.10 Creating Low-poly Tire Model. 
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Step 12: Let’s UV unwrap both of them and rename them to Tire_high and Tire_low 

accordingly. Export them as (.fbx) format. 

 

 
Figure 4.1.11 UV Unwrap and Layout (High-poly Version). 

 

 
Figure 4.1.11 UV Unwrap and Layout (Low-poly Version). 
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Step 13: Open the (Tire_low.fbx) File on Substance Painter. Go to Texture Set Settings 

and Bake Mesh Maps at 2048 resolution. Select the (Tire_high.fbx) file for High 

Definition Meshes slot; Match by Mesh Name; Antialiasing Subsampling 4x4 and Bake 

lambert1 Mesh Maps. 

 

 
Figure 4.1.12 Bake High-poly Normal Map to Low-poly Mesh. 

 

Step 14: Apply Rubber Tire smart material to the lambert1 Layer stack. 

 

 
Figure 4.1.13 Texturing in Substance Painter. 
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Step 15: Take UV Snapshot of Tire_low from Autodesk Maya and UV Map the text on 

the tire using Adobe Photoshop. 

 

 
Figure 4.1.14 UV Snapshot. 

 

 
Figure 4.1.15 Texturing in Photoshop. 
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Step 16: Import the image into Substance Painter as Alpha, add a fill layer, turn off 

everything except height and put the image as height map. Adjust the height by using add 

levels to the fill layer targeting Height as Affected Channel. 

 

 
Figure 4.1.16 Texturing in Substance Painter. 

 

Step 17: Go to File> Export Textures> Configuration and create a new preset for Blender 

3D Export and Export textures in (.jpeg) file format using this preset. 

 

 
Figure 4.1.17 Export Textures Preset. 
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Figure 4.1.18 Export Textures Settings. 

 

Step 18: Import (Tire_low.fbx) file on Blender 3D and assign all the textures correctly and 

export as (.glb) file format. 

 

 
Figure 4.1.19 Texture Node Setup in Blender3D. 

 

Now, finally, we can compare the file size of both the high-poly and the low-poly mesh. 

High-poly mesh without texture file size about 12 MB. On the other hand, low-poly mesh 

with details and texture file size exactly 977 KB which is a huge difference. So, this is the 

process of optimization for web. 
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4.2 Online Compressing Solution 

Step 1: Export as GLB file according to the settings below along with textures from 

Substance Painter to a folder and make sure to check Export shaders parameters which 

will create a (.json) file. 

 

 
Figure 4.2.1 Export Textures Settings for Web. 

 

Step 2: Go to https://glb-packer.glitch.me/ web address and check Convert PNG to JPEG 

(beta). Select all the texture file, GLB, GLTF along with (.json) file from the folder. Drag 

and drop them to the browser window and the compressed file will be downloaded 

automatically.  

 

 
Figure 4.2.2 GLB Packer Website. 
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• Important thing to note that, the model size before compression was 5.29 MB and 

afterward it was downsized to 1.89 MB. Now, this model will load quicker in the website 

than before.  

 

 
Figure 4.2.3 GLB Size Comparison. 

 

• But we can use this process only with fully opaque models. Converting PNG to JPG will 

lose the transparency of the model. In that case we need to go to https://viewer.seekxr.com/ 

web address and we can delete some texture maps like ambient occlusion of flat meshes 

or normal map where there are no details. 

 

 
Figure 4.2.4 Modify GLB on seekxr Website. 
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CHAPTER 5 

Creating Video Representation 
 

This chapter will be discussing about the software uses and workflow for creating video 

representation of the 3D models. 

 

5.1 Video Rendering in Marmoset Toolbag 

 

Step 1: Export Textures with Diffuse, Normal, Roughness, Metallic, Ambient Occlusion 

and Emissive map from Substance Painter. We can export with 2K resolution and PNG 

format. 

 

 
Figure 5.1.1 Export Textures Settings for Marmoset Toolbag. 
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Step 2: Open Marmoset Toolbag and go to File> Import Model and import FBX file. 

 

 
Figure 5.1.2 Import Model to Marmoset Toolbag. 

 

Step 3: Apply all the textures, use light, backdrop, change HDR and build atmosphere. 

 

 
Figure 5.1.3 Applying Textures. 
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Step 4: Selecting Main Camera we can change Depth of Field, Flare, Distortion. We can 

add Post Effects. Selecting Render we can turn on Global Illumination, Ambient Occlusion 

and change the resolution. We can add manual keyframes to the model or containing folder 

in the timeline and also use automatic Turntable. 

 

 
Figure 5.1.4 Adding Keyframe for Animation. 

 

Step 5: Go to Capture> Settings and set the Aspect Ratio, Sampling and file format to 

render to. Press F5 to start video rendering. 

 

 
Figure 5.1.5 Render Setup. 
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CHAPTER 6 

Some Common Problems and Their Solutions 
 

This chapter will be discussing about some common problems during 3d model production 

process and how to fix them. 

 

6.1 Unit Mismatch Issue 

If we export FBX format from Maya in any unit other than meter; Substance Painter won’t 

support it and there will be a unit mismatch. Substance Painter is mainly a texturing 

software for game engines like Unreal Engine, where the compatible unit is meter. So, we 

must export FBX in meter from Maya. 

 

6.2 Vertex Color Issue 

Sometimes we accidentally press the hotkey for adding vertex color to a mesh and in the 

viewport, we see the colorful textures without any issues. But, when we export the GLB 

file, the texture comes out grayscale. The solution to this problem is, go to Mesh Display> 

Color Set Editor and Delete all Vertex Colors. 

 

 
Figure 6.2.1 Check for the Vertex Color. 
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6.3 Multiple Texture Set Issue 

Sometimes we import multiple meshes from different files which can have different 

texture sets and combine them. For this reason, we get missing or mismatched UV Layout. 

The solution for this problem is, go to UV> UV Editor> UV Sets> Copy UVs to UV Set> 

map1 

 

 
Figure 6.3.1 Check Texture Sets. 

 

6.4 Boolean and Combine Issue 

This mesh is made using Deference Boolean and multiple meshes Combine.  

 

 
Figure 6.4.1 Boolean. 
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In Substance Painter, when we Bake Mesh Maps, the model structure breaks. 

 

 
Figure 6.4.2 Incorrect Baking. 

 

Solution 

In Maya, go to Mesh> Separate 

 

 
Figure 6.4.3 Separated Mesh. 
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Go to Mesh> Clean Up option box and set up like the image below. 

 

 
Figure 6.4.4 Mesh Cleanup. 

 

Import the exported FBX from Maya to Blender 3D, select elements one by one, got to 

Object Data> Normals and tick Auto Smooth. 

 

 
Figure 6.4.5 Apply Smooth Mesh in Blender3D. 
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Bake Mesh Maps in Substance Painter again and now the problem is fixed. 

 

 
Figure 6.4.6 Accurate Baking. 

 

6.5 Layout According to Material Issue 

Always select all the components with the same materials at once and Layout UVs at the 

same UV Set. 

 

6.6 Tweaking the Shape of a Hi-Res Mesh Issue 

The simple solution for tweaking a mesh after converting it into a High-Resolution mesh 

is using Lattice Deformer. 

 

6.7 GLB to FBX Convert and Editing Issue 

When we export a file into GLB format, the mesh gets triangulated and breaks into pieces 

and if we want to import and edit a GLB model, we need to merge the separated overlapped 

vertices using very small threshold. 
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CHAPTER 7 

Discussion 
 

This chapter will be discussing the future potential opportunities as well as real-life 

dangers that we might face during using augmented reality. There are some previous 

records of damages and fatality and some security concerns also. 

 

7.1 Future Potential Opportunities 

So, let’s say we are planning on spending tens of thousands or even millions of dollars on 

some stunning AR experiences to bring our brand to successive level as they buy our 

product. Great! our customers can love it! however what happens once the next phone 

comes out? And what concerning those AR glasses we've heard of? How do we sustain 

with devices like Magic Leap and HoloLens? Do not they need utterly totally different 

formats, apps, and installations? These are all valid queries. 

 

The AR world has passed its state of infancy, however it's a fast-moving toddler that's 

nearly not possible to stay up with. And rather like a toddler that never stops growing, it's 

high-priced to stay up with and develop for each platform. For many brands, it's downright 

not possible. They need to select a platform or two and simply roll with it, hoping to 

capture no matter audience can be on those platforms. 

 

The world will alter quickly when Apple launches its AR glasses. Let’s take an instant to 

explore the probabilities of AR glasses, and we may be astonished at how game-changing 

this technology are. But again, attempting to stay up with this technology for a brand could 

be a drain. We nearly wish to rent an entire technology team to manage this for our brand. 

But, even for the largest brands, this is often nearly impossible because of the huge 

maintenance that will be needed for each single solution. Already these days, there are half 

a dozen major ways in which to deploy AR, and that they all use totally different 

approaches, technology and content! So, we must try to keep up with the AR technology 

and grab all the opportunities it can give in the near future. 

 

The Future of Augmented Reality Augmented reality may be a technology that has been 
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incorporated into many various aspects of our life. however, I think that AR has a lot of 

potential than it is given credit for. the use of AR in games like Pokémon Go are 

Brobdingnagian success stories, however the fact of AR and also the potential it is to 

impact our lives can’t be unheeded.  

  

AR will remodel our lives for the better. There are cars that are already incorporating 

displays that project our speed, GPS routes, and different information that one might have 

or just wish onto the windscreen of the automobiles more easily visible than it is presently.  

  

Google Glass is already being used within the work surroundings in factories as a way of 

potency. augmented reality is additionally serving to automobile mechanics as they service 

cars, and it is conjointly serving to train medical professionals and future medical 

professionals furthermore.  

  

The reality is, as augmented, because it is also, the advances in technology are heading 

within the right direction and can revolutionize the method we have a tendency to live for 

the better. 

 

7.2 The Dangers of Augmented Reality 

 
7.2.1 Reality Modifications 

In a paper entitled "Death by Pokémon GO," scientists at the Krannert School of 

Management at Purdue University argue that the game induced "a disproportionate rise in 

vehicle accidents and related harm to vehicles, personal injuries and deaths in the vicinity 

of places, called PokéStops, where consumers can play the game while driving." 

Exploitation of data from one municipality, the paper extrapolates what that might mean 

nationwide and concluded " the rise in the amount of accidents attributable to the 

introduction of Pokémon GO is 145,632 with an accompanying rise in the amount of 

accidents of 29,370 and an accompanying increase in the number of deaths of 256 between 

6 July 2016 and 30 November 2016." The authors calculate the price of these crashes and 

fatalities at between $2billion and $7.3 billion for constant period. What is more, quite one 

in 3 surveyed advanced web users would love to change troubling parts around them, like 

garbage or graffiti. They'd wish to even modify their surroundings by erasing street signs, 
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billboard ads, and uninteresting shopping windows. So, it appears that AR is the maximum 

amount a threat to firms because it is a chance. Although, this might be a nightmare to 

various brands that don't manage to capture client imaginations it conjointly creates the 

danger that the wearers of augmented reality glasses might become unaware of 

encompassing dangers. customers wish to use augmented reality glasses to alter their 

surroundings into something that reflects their personal opinions. Around 2 in 5 wish to 

alter the way their surroundings look and even however individuals appear to them. 

 

 
Figure 7.2.1.1 Playing Pokémon GO while driving. 

 

 
Figure 7.2.1.2 Car crushed during playing Pokémon GO. 
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Next, to the potential privacy problems that are represented below, overload and over-

reliance problems are the biggest danger of AR. For the development of recent AR-related 

product, this suggests that the user-interface ought to follow certain guidelines as to not 

overload the user with data whereas conjointly preventing the user from over-relying on 

the AR system specified vital cues from the surroundings are incomprehensible. This is 

often referred to as the virtually-augmented key. Once the secret's unheeded, people might 

not desire the real world any longer. 

 

7.2.2 Privacy Concerns 

The thought of contemporary augmented reality depends on the flexibility of the device to 

record and analyze the environment in real-time. Due to this, there are potential legal 

considerations over privacy. While the primary modification to the united states 

Constitution permits for such recording within the name of public interest, the constant 

recording of an AR device makes it troublesome to try and do thus while not conjointly 

recording outside of the general public domain. Legal complications would be found in 

areas where a right to an explicit quantity of privacy is anticipated or where proprietary 

media are displayed. 

 

In terms of individual privacy, there exists the benefit of access to information that one 

shouldn't promptly possess about a given person. This is often done by biometric 

identification technology. If AR automatically moves data about individuals the user sees, 

something can be seen from social media, criminal records and marriage status. 
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CHAPTER 8 

Conclusion 
 

In this Report I have shared my own experiences, problems that I faced during 3D 

modeling and texturing for Web-based Augmented Reality and their solutions. Also, I have 

shared the efficient way of modeling, texturing and optimizing website-compatible 3D 

models for AR. Last 6 months I was doing several projects for DataSoft Systems Limited 

Bangladesh. I have learned real-life use cases of the combination of AR and 3D. Made 

product models for using them in websites. A customer can interact with the product, place 

the product virtually to the real environment and can experience the look, measure the 

product comparing the space they have before buying. 

 

I have faced various issues during doing these projects. Done some research and 

development online and solved most of the issues. But, also failed to solve few of them. I 

am still searching for making the models more efficiently spending as less time as possible. 

Learned some very useful shortcuts that made the production process much comfortable 

and less tedious. Through this Report I represented the complete and proper pipeline and 

workflow of modeling, texturing and optimizing the 3D models for website compatibility. 
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