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ABSTRACT 
 

I create a 3d animation short film about save the nature where Fireflies are the role model 

of the story. 3D Animation is the craft of utilizing movement to bring characters, vehicles, 

props, and more to life inside TV shows, movies, and games. Animation is important 

because it makes us be able to tell stories and communicate emotions and ideas in a unique, 

easy-to-perceive way that both small children and adults can understand. Animation has 

helped connect people throughout the world in a way that sometimes writing and live-

action films cannot. As an animated character, the character feels like their own being. Idea 

making is first step of building story and story is the base of 3d Animation production. At 

the beginning of the project, I follow full 3d animation pipeline and prepared the story 

board for the first key to visualize the story. Then I start draw character design and 

environment design. After design all element I start modeling, UV mapping, rigging using 

Autodesk Maya. After finishing all model and UV mapping then I start texturing in 

Photoshop. Then I animate my animation in Maya and render it in Arnold. After finishing 

my render I composite it in Adobe after effects and premier pro. So, My 3d Animation 

short film project aware people to create a social awareness about save natures. 
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CHAPTER 1 

Introduction 

 

Fireflies are the beautiful creature of God. They communicating with their light, each 

blinking pattern an optical signal to a potential mate. But sadly, as with so many of the 

Earth’s creatures, fireflies are disappearing all over the world. The clearing of forests, the 

destruction of wetlands, the use of toxic chemicals in agriculture and on residential lawns 

and gardens are all to blame. Adult fireflies live only long enough to mate and lay eggs. 

Catching fireflies in glass jars is a nostalgic pastime for children on a summer’s evening, 

but how sad it is to waste one precious moment of a firefly’s brief existence trapped in a 

glass prison. 

Nature and ecosystem in nature are in perfect concord where every residing and nonliving 

component has a role to play in making the atmosphere and surroundings work perfectly 

so that all animals, plants, microorganisms, and nonliving things can coexist creating a 

perfect stability amongst them. We, the humans have caused several imbalances in the 

nature for numerous thousands of years and now, it is the time we turned round and fixed 

a number of the negative impacts at the globe 

Fireflies also one of the creature of nature. In my 3d animation project aware the people to 

save the wildlife ecosystem. This project consists in the realization of an Animated Short, 

combining 3D techniques to achieve a professional quality product. One of the objectives 

of the project will be create a professional visual piece, which will help me to demonstrate 

my skills to the professional world when looking for job in this field of the industry. 

This project provide a animated 3d Animation film. The Visual are based on, Fireflies and 

a girl character. 
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CHEPTER 2 

Software and 3D Animation Pipeline 

 

2.1 Software I used for this animation project. 

 1. Adobe Photoshop: I used Photoshop cc for design and texturing for this project. 

 2. Adobe Illustrator: I used Adobe Illustrator cc for Title design and texturing. 

 3. Autodesk Maya:  I used Autodesk Maya (17,18,19) for modeling ,UVmapping 

     Rigging, Animation, Lighting and Rendering. 

 4. Adobe Premiere Pro : I used Adobe Premiere Pro cc for Post production , Editing                   

     And Color Correction. 

5. Hardware Configuration : I used my personal desktop computer for this project . 

 Processor : Intel core i5-6500 ,3.20 GHz 

 RAM : 16 GB DDR4 

 1 TB Hard Drive  

 

2.2 3D Animation Pipeline. 

I follow the full animation pipeline process: 

1. Pre-Production 

 Idea : An animation is really just a moving story. So you need to have a story idea 

before you can begin. 

 Story: Story making based on your idea .When I develop the idea, then I write the 

story.    

 Script: A screenplay, or script, is a written work by screenwriters for a film, 

television program or video game. So, I write script for my animation project. 

 Story Board: A storyboard is a graphic organizer that consists of illustrations or 

images displayed in sequence for the purpose of pre-visualizing a motion picture, 

animation, motion graphic or interactive media sequence. 

 Animatic: Like storyboards, animatic are utilized for pre-picturing the film before 

creation begins. Animatic are critical for making an enlivened motion picture, since 

they let you see what the motion picture may resemble just because. This is when 

you first get a sense of the pacing, the rhythm and the progression of your film. 
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2.Production  

 

 Modeling: In this part we have to all 3d models and props design and environment. 

 Texturing: After complete all 3d models .Then we have to do all UV mapping and 

texturing to get the perfect color of all models. 

 Rigging:  rigging is the process of creating a skeleton for a 3D model so it can 

move. Most commonly, characters are rigged before they are animated because 

if a character model doesn't have a rig, they can't be deformed and moved 

around 

 Animation: 3D movement. Energizing items that show up in a three-

dimensional space. They can be pivoted and moved like genuine articles. 3D 

activity is at the core of games and computer generated reality, however it might 

likewise be utilized in introduction designs to add style to the visuals. 

 Lighting: A point light throws beams toward each path from a solitary, little 

source in 3D condition. It has no particular shape and size. Point lights can 

include "fill lighting" impact to a 3D scene. 

 Rendering: 3D rendering is the 3D computer graphics process of converting 

3D models into 2D images on a computer. 3D renders may include 

photorealistic effects or non-photorealistic styles. 

 

 

3. Post-Production  

 Compositing: Compositing is the mix of numerous layers of pictures or video 

components to render a last still or moving picture. The mix of layers can be a 

physical or programming based activity. 

 Sound Editing: We depict sound altering as a specialty of delivering extraordinary 

quality sounds for blending, usage and preparing. In more straightforward words, 

sound altering is a relentless undertaking of making boisterous and lousy accounts 

sound great. It is one of the procedures that make the video entirety. 

 Color Correction: Color correction alludes to changing white and dark levels, 

presentation, difference, and white parity to give you look with accurate, 

unprocessed-seeming colors. 

 Final Output: After complete editing go to video render output in MP4 or other 

video format. 
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CHAPTER 3 

Pre – Production 
 

3.1 Idea and Story Building: 

From the thought of doing something helpful for our awareness through my work, I started 

to think about this project which will not only fill my goal but also will be helpful for our 

awareness about save the wildlife nature. 

My story is based on an Adventure of a Fireflies and a girl character. Once she reading on 

table at a village house. Suddenly the electricity is off and a fireflies come inside by 

window. Then she see closely and she dream that go outside and see the moon light and 

beautiful environment and go forward behind the fireflies. Suddenly she stopped and the 

moon hide by trees then see look a fireflies on her hand, and fly from her hand. And lots 

of fireflies come to the frame. See feeling very charming and great. Suddenly see woke up 

and realize that it was dream with beautiful fireflies. Then see free the fireflies from the 

Glass jar. That mean see realize that Catching fireflies in glass jars is very bad for natural 

ecosystem and how sad it is to waste one precious moment of a firefly’s brief existence 

trapped in a glass prison. 

 

 

 

3.2 Script: 

Any film/Video production project appears with the script/screenplay. It is the Bible of the 

film that everyone working with the script on the shooting of the film. After developing 

the story our next step was to establish a complete screenplay. Script contains detailed of 

shot & camera direction for every single scene. 
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Figure 3.2.1 :  Scan Copy of Script. 
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3.3 Story boarding: 

A story board is a realistic coordinator that furnished the watcher with an elevated level 

perspective on a task. After finished my script writing I began to make a storyboard. I work 

in subtitle with the drawing .I try my best to create a good and detailed story board for the 

goal. 

 

Figure 3.3.1 :  Scan Copy of Story Board 
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CHAPTER 4 

Production 

4.1 Character design 

At first, I required character Design for my animation project. I draw girl character in front 

and side views by sketching. 

 

 

 

Figure 4.1.1 : Character Drawing of Girl 

4.2 Modeling 

Modeling is very important to look of the character and all props and environment .After 

character design completed. I start modeling in Autodesk Maya. I also describe my 

modeling technique. 
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Figure 4.2.1 : Import the drawing image reference 

Step 1 : At first I import the darawing image for reference . It is very easy to modeling of 

character design . Front view > Image Plane> select image front in Z axis  and Side view 

> Image Plane> select image front in X axis . 

 

Step 2: Then Create new polygon Cylinder for body which edge subdivision is ( 12 ).Then 

go to vertex and make a body shape with reference image . And increase the edge loop by 

Insert edge loop tool  .Then again select vertext and make a perfect shape . 

adjust the vertex to the face reference image . Then make it to perfect shape of face and 

body part . 
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Figure 4.2.2 : Create body part by image reference 

Step 4: When complete the body shape then create new cylinder for hand > leg which edge 

subdivision is ( 8) . Then go to vertex and make a hand and leg shape .Press 3 for smooth 

mesh . 

Figure 4.2.3 : Create head part by image reference 

Step 5: Then bridge the edges from body >hand and leg .Then create new sphare and 

subdivision (12 ) for head part. Select vertex and crate shape by the head reference. 
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Figure 4.2.4 : Make duplicate speacial body part . 

Make sure when we want to duplocate speacial the pivot point of body must be in center 

of grid. Press (d and v ) and adjust with mouse left button for move pivot point to middle 

last vertex of body . Then press x and mouse left button , then move pivot point to center 

of grid . 

 

Figure 4.2.5 : Create eye, eye brow ,teeth, toung part . 
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Figure 4.2.6 : Create hair by image reference . 

Step 6: When I complete the full body then create the eye by sphare ,eye brow,teeth and 

tongue by poly cube. 

Step 7: Then create the hair by sphare .It was so hard to create the perfect shape .But finally 

I do the hair part .Then create the dress by copy body and delete the other faces . And make 

dress shape by adjust vertex point . 

Figure 4.2.7 : Create dress by image reference . 
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Figure 4.2.8 : Complete modeling of character. 

Figure 4.2.9 : Create Fireflies modeling by image reference . 

I applied same technique for other all modeling like the firefly. Firstly I import 

reference image of firefly .Then create new cylinder for body and cube for 

head and leg.  
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Figure 4.2.10 : House modeling  

I applied same technique for other all modeling of house, chair, and table. I 

create this part by poly cube.  Then applied extrude and insert edge loop tool. 

And all other tees and environment create Maya content browser. 

 

Figure 4.2.10 : House Interior modeling 
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CHAPTER 5 

Texturing 

5.1 UV Mapping 

When complete all modeling next step is UV mapping for perfect texturing in all 3D 

models.  Following steps are given below. 

 

Figure 5.1.1:  Planner Mapping Options 

Step 1 : Select Object > Workspace: UV Editing > UV Editor > Planner Mapping options 

> Select (Project From: Z axis) cause the character front is in Z axis. 
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Figure 5.1.2:  Cut UV edges 

Step 2 : Select Edges > Cut UV edges ( to all edges showed in the screen shot ) 

Step 3: When complete Cut all the UV edges. Then  > Select UV shell > Unfold ( Unfold 

the UV shell for unwrap the skin ). 
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Figure 5.1.3:  Unfold UV shell 

Step 4: After Unfolding all UV Shells .Then select all UV shells > apply: Layout [key 

short: Ctrl + L] 

 

 

Figure 5. 1.4:  Layout UV shell 

Step 5: Select all UV shells > UV Snapshot Options > Size X(px) & Y(px) : 2048 >Image 

Format : Targa > Then Brows..: name and select the folder where you want to save the 

snapshot file. 
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Figure 5.1.5:  UV Snapshot Options 

I apply same UV mapping technique in all others models and props need on my project. 

5.2 Texturing 

After completing perfect UV mapping .I import the UV snapshot in Photoshop. Then drawing the 

perfect color on skin, eye shadow and lip. 

 

Figure 5.2.1:  Import UV Snapshot in Photoshop 
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Figure 5.2.2:  Painting color in Photoshop 

I create a new layer for body fill color. Then 3rd layer for eye shadow  and 4th layer for 

cheek color . Then 5th layer for lip color . 

 

Figure 5.2.3:  Dress Texturing in Photoshop 

I apply same technique for dress and others models texuring .Then save the file in 

Name.ps format or jpeg format . 
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Figure 5.2.4:  Import and Applying Texture  

Then import the texure file in maya material . Select object > Assign new material > maya> 

blinn : Color > File attributes : Image name > Click Folder > Select the Texure file > open. 

I applied same technique for all model texturing. 

 

Figure 5.2.5:  Import and Applying Texturing on house 
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CHAPTER 6 

Rigging 

 

6.1 Rigging Process 

Rigging is the process of creating a skeleton for a 3D model so it can move. Most 

commonly, characters are rigged before they are animated because if a 

character model doesn't have a rig, they can't be deformed and moved around Camera 

animation. 

6.2 Body Rigging  

I used advanced skeleton for my character rigging. It is a FREE Maya rigging plugin: 

“Advanced Skeleton can create rigs with unlimited body configurations, 3 heads, 5 legs, 100 

fingers, & anything goes. Not only creatures, but you can also rig props, vehicles, and just about 

anything. 

Figure 6.2.1:  Model clean and models it is semetric 
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Step 1: At first just drag the install file in Maya scene. Then click the advanced skeleton 

option. Now, Select model > Model Clean option > Model check > If the model symmetric 

now go for rigging.  

Figure 6.2.2:  Import model reference and import biped 

Step 2: Then click: New scene> reference > Open the Maya model file. Click > Body > 

Import ( biped.ma ). 

Figure 6.2.3:  Fit the joints inside fingers 
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Step 3: Then select parent and child joints from skeleton and fit inside the body’s all parts. 

Root joint in in the middle of body. 

 

Figure 6.2.4:  Fit the all joints inside left side of body 

Step 4: When complete all joints fit inside the body. Then go to build section and Click: 

Build Advanced Skeleton.  All joints and controller will create automatically. 

 

Figure 6.2.5: Build skeliton and controlers  
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Step 5: Then chacked all controler in perfect positon . If need to controler size to big .Go 

vertex of controler and select the vertex and change to right position. 

 

Figure 6.2.6:  Bind skinning options 

Step 6: Select Deform option1> + Select deform joints > Set smooth bind options > Edit > 

reset settings > Bind to : Joint Hierarchy > Bind method : Closest in hierarchy > Skinning 

method : Dual quaternion > Max Influences : 3 > Apply. 

 

Figure 6.2.7: Rotate the controlers and check the Bind skin  
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Step 7: Then Rotate the controlers and check the Bind skin is perfect . If any problem on 

skin deformation . Then Deform ( DeltaMush ) :  Harden weights >  Apply Delta Mush. 

6.3 Face Rigging  

When complete the body part rigging. Then next step is to face rigging. 

Step 1: Go to Advanced Skeleton face options > At first create: Face Fit Skeleton Node. 

Fit it lower circle under the character’s jaw and upper circle just above the character’s head. 

Figure 6.3.1: Create face skeleton 

Step 2: Now select the face geometry from the Outliner > Click the option: Face . Select 

body and all inside head part: Click the option: All Head. Apply same technique for Right 

eye, Left eye, Upper Teeth, lower teeth and Tongue. 

Figure 6.3.2: Edge loop of Eye lid  



25 
©Daffodil International University  

 

Step 3: Fit > Press: Eyeball. Then, Click The ( ? ) Question mark of  Eye lid outer .It is 

face help image to show that which edge loop outer to select .Then press the Eye lid outer 

option. Then apply the same technique for Eye Lid Main, Eye lid Inner, Lip Outer, Lip 

Main, Lip Inner. 

  

Figure 6.3.3: Edge loop of lip  

Step 4: Then, Click The ( ? ) of  Eye Brow inner .It is show that which vertex to select. 

Then select the vertex and press the Eye Brow inner option. Then apply the same technique 

for Eye brow Outer and eye brow middle.   

Figure 6.3.4: Face help image for face rigging 
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Step 5: Then, Click The ( ? ) face help image of  Fore Head. It is show that which 3 vertex 

to select. Then select the 3 vertex and press the Fore head option. Then apply the same 

technique for Jaw pivot, Jaw corner, Jaw, Throat, Cheek, Cheek bone, Cheek raiser, Smile 

Bulge, Frown bulge, Nose, Nose under, Nose corner. And no selection needed for (Jaw 

curves and Tongue ) just press the option.  

 

Figure 6.3.5: Build advanced face rigging 

Step 6: Then apply: Build Advanced Face .It will automatically rigging the full face with 

controllers. Then select body > Skin > Paint skin weights tool > Select hierarchy> Then 

skin paint operation by smooth and replace until the perfect movement of joints. 

Figure 6.3.6: Paint skin weights tool 
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CHAPTER 7 

Animation 

7.1 Animation Process  

3D Animation, Energizing items that show up in a three-dimensional space. They can be 

turned and moved like real articles. 3D movement is at the center of games and PC created 

reality, anyway it may in like manner be used in acquaintance structures with add style to 

the visuals. 

 

Figure7.1.1 : Key animation in time slider 

At First I import the character file in various scene in maya. Then adjust with the scene.  

Step 1: Select the controller > Then Rotate that how I want > Go to time slider > Press key 

to : s  to save the selected key. Also we can selected key by channel box.   

Step 2: Then go to the Graph editor. Then adjust the vertex point for perfect animation 

play. 

Step 3: If any wrong key in the time slider. Then select the key by Shift+ drag by left key 

mouse. Now mouse right click > then you can cut , copy, paste delete any one just click 

the command. 
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Figure7.1.2 : Adjust animation by graph editor 

7.2 Cycle Animation  

I used the animation cycle in firefly feather. At first it’s pivot point position to head joint. 

Then animate two feather in same frame. I used 0 to 4 frame to open and close the feather. 

Then Go to graph editor > Keys > Post infinity > Select the :Cycle 

 

Figure7.2.1 : Firefly feather cycle animation  

 



29 
©Daffodil International University  

 

7.3 Constrain  

Constrain animation is to move the object by another object. I used constrain animation for 

free the firefly from the jar. First Select the hand controller then select the object > 

Animation > Constrain > Parent.  

Figure7.3.1 : Constrain animation for jar opening 

7.4 Camera Animation 

When complete the character animation. Then create the camera and animation key 

animate in time slider and apply cinematography. I follow the camera shot division.

 

Figure7.4.1 : Camera animation  
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CHAPTER 8 

Lighting & Rendering  

8.1 Lighting technique  

A point light tosses shafts toward every way from a singular, little source in 3D condition. 

It has no specific shape and size. Point lights can incorporate "fill lighting" effect to a 3D 

scene. Lighting and rendering define visual look of production. I have used Maya Arnold 

for lights and as a render. 

 

Figure 8.1.1 : Create area light from arnold 

Step 1: I used 3 point lighting technique. Firstly Create light from: Arnold > Light > Area 

Light. Now position it front of the character as a fill light. Again create another light for 

key light. Then another for back light. 

Step 2: Select the area light > Attribute Editor > Arnold light attribute > select color which 

I want > intensity: 1 – 5  ( depends on render look )  .Exposure : 1 -14 ( depends on render 

look) . I used Arnold render view then adjust the light intensity and exposure. 
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Step 3: I also used for color temperature in area light to create night scene with electric 

bulb.  

 

Figure 8.1.2 : Directional light to create moon light effect 

Step 4: Create Directional light from Arnold. This light for create moon light effect. Select 

directional light attribute > Color: Light blue > intensity: 1.5   

Figure 8.1.3 : Mesh light to create firefly light effect 

Step 5: I used a sphere on firefly group . Then Go to Arnold Translator: Conver to mesh 

light > Intesity: 1 > Exposure : 1 > open : Light visible option> Sample: 3 for all light in 

arnold. 
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8.2 Rendering technique  

3D rendering is the 3D computer graphics process of converting 3D models into 2D images 

on a computer. 3D renders may include photorealistic effects or non-photorealistic styles. 

Figure 8.2.1 : Arnold render view 

Step 1: Select Arnold> Arnold render view > Then see the look what I want and adjust the 

lighting intensity and exposure. 

 

Figure 8.2.2 : Common options of render settings 
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Step 2: When I get the perfect look on render view. Then go for final render. Render 

Settings > Select render using : Arnold renderer > Common : Use file name > Image 

format: jpeg > Color space > Use view transform>frame /animation ext: name#.ext > write: 

start and end frame > by Frame: 1 

Figure 8.2.3 : Arnold renderer settings 

Step 3: Arnold Renderer :Sampling> Camera: 2 >Diffuse: 4 >Specular : 2 >Transmission: 

2> SSS: 1 > Volume indirect: 1>  

Step 4: Menu Set : Rendering > Render > Render Sequence options > Select the camera > 

and select file location to save the images . 

Figure 8.2.4 : Render Sequence options 
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CHAPTER 9 

Post-production 

9.1 Compositing  

For getting the output of the total project animation I start compositing in Adobe Premiere 

pro .Adjust color and effects for the perfect visual look. 

 

Figure  9.1.1: Compositing in Adobe Premiere pro. 

9.2 Sound mixing 

I add bckground sound music from free music in Adobe Premiere Pro 2017. Sound editng 

is the essential piece, and sound blending is assembling each one of those pieces to make 

a last, consistent item. 

 

 Figure  9.1.1: Sound editing in Adobe Premiere pro 
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CHAPTER 10 

Conclusion 

For this project I have watched many animated short films, among them more than anything 

were 2D and some were 3D Animation. I was motivated from this visuals of the movies I 

watched. 

With the visualization of this project I have tried to let the people aware about save the 

nature and ecosystem. I tried to show my skills in 3D animation sector and experiences 

during our university life. In this department I have learned and realize about motion and 

all graphics and Animation etc. I also thinking that I will make more animated short film 

in future. We also believe that our short film has a good morality and meaning which can 

make increase the awareness among the people. Through this Report I represented the 

complete and appropriate pipeline and work process of complete 3D animation. 
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