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ABSTARCT 

 

In this modern era, everything is going to be digitalized based on internet. Globalization 

networking is so important for a corporate office. Everything is need to upgrade. To upgrade a 

network need to infrastructure design. Each and every Company and Institute need a safe and 

efficient connectivity which can easier to accelerate their work. So, we decided to design a network 

infrastructure for corporate office as our final year project. But establishing a network 

infrastructure is never being an easy task. Our design is about to connect an office and their 

branches to the same network to safe and faster connectivity through internet. For designing the 

project, we used some networking devices, servers, personal computers, ISP connection, etc. For 

a design security and durability is such an important thing. We try our level best to design this 

project, so that design will be satisfied while the company will be benefited.  

During COVID 19 we used virtual simulator for designing this project. We used GNS3 Software 

to design this project and after implementing we tested this project on virtual machine (VMware). 

Our design will be usable not only corporate office also other institute, companies. This is not only 

a work for us, it was a passion which lead our team member to give the full effort to complete it. 
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CHAPTER 1 

INTRODUCTION 

1.1 Introduction 

The project about Design and Implementation of Network Administration for Corporate office is 

an important aspect of networking which will make the networking sector more secure and easy 

to use for corporate offices. This project builds a relationship that brings a head office and their 

branches under a specific network from where easily maintain uninterrupted connect to share their 

data also can observe from a particular place. By the design user can exchange data easily where 

no need any kind of hassle to slow or data mess. We paid most attention about security and strong 

connectivity because everything becoming insecure. We have too much concern about that. We 

design a project which can be more user friendly which makes the environment sturdy. The design 

implement on a simulator software which name is GSN3. We use some networking devices, 

servers, virtual machine to different usability and also some user. We use virtual user as head office 

and their branches. After that the devices and servers connect on a particular network like 

MikroTik router. After configuration the devices and server it is an accomplished work. After 

implementation we tasted this design on several ways.  

 

 

1.2 Project Goal 

Our final year project about Design and Implementation of Network Administration for Corporate 

office. We design this Network Infrastructure to provide a batter service to the corporate offices. 

Each office contains their branches and the project goal about establish a network system that will 

connected head office to their branches. We will provide a network administration to provide also 

different kind of services. Where they can store and access these data by several user. Also, our 

goal is to provide a secure and faster network system. The main goal of this project is develop our 

network infrastructure to desire a batter and strong communication which is really needed for our 

corporate office. The offices are belongs various important and emergency services so they need 

a network where they can get a super sturdy communication to connect their all services at specific 

platform.
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1.3 Motivation 

As a student of Computer Science and Engineering, we have been interested in Networking. We 

also completed our six months internship after Diploma Engineering about Networking. The 

Internship has ponder to lead us a design implementation about networking. This project has given 

us opportunity to find out our inside questions about designing and implementing about 

networking administration .Our knowledge of networking field at the start was casual. We know 

generally about network developing without knowing anything specific about the networking 

devices, servers and overall structure of a networking that we using. As this a subject we interested 

in making our career in designing a network infrastructure and how this can be efficient by user. 

It seems a natural choice of study which we knew would be both challenging and interesting. 

 

1.4 Objectives 

 

The core objectives which have been designated as fundamental to the project are: 

• Developing a networking infrastructure for all corporate offices, Institute, etc. 

• Learning more about networking through this project. 

• Making a positive view of computer networking. 

• The immediate goal of our project is to anticipate competitive developments and move 

institute formation. 

• Achieve a better understanding of the total competitive arena.  

• To provide a secure and faster service. 

• To provide comparatively money saving services. 

• Gain experience about networking devices and servers through this project. 

• To establish future career through this project. 

• To desire to income of sources.
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1.5 Scope of Studies 

 

This report is based on Networking Infrastructure design and Implementation. Along with this, the 

project report will also specifically describe the whole Network System about Corporate Offices. 

This project is mainly valuable for the Networking related organizations to understand the network 

system that includes several networking devices, physical and wireless devices communications, 

routing protocol and configuration, network monitoring tools, servers, network security tool, and 

MikroTik router and so on. 

Another thing is data storing easily, data access from branch office to head office, transferring files 

through private networking. Data will be encrypted on servers using some protocol to secure the 

data from hacker also unauthorized user. 

Another thing is security using Firewall and VPN. Firewall is a security device which protect the 

networking system from unauthorized user or hacker. Virtual Private Network (VPN) is also make 

that network private or more secure. When branch office send any important file to another branch 

office or head office that time it need to be secure. The firewall and vpn ensure that security to 

protect from any threat. 

 

1.6 Outcomes 

 

When we start our project, we were very focused about expected outcomes. We found successful 

accomplished our project. We are proud to say that this project will bring positive outcomes at 

corporate arena. Few of major outcomes of our project is given bellow: 

• The way of learning such as important continent about networking. 

• The way of learning about multiple devices and servers. 

• Provide an as expected consequences. 

• Better proactive strategy. 

• Better understanding about networking.
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1.7 Report Layout 

We described our whole project about designing and implementing about Design and 

Implementation of Network Administration for Corporate Office through this report. We divided 

our whole report into sixth different chapter. 

First Chapter: I have described in this chapter, Introduction, Our goal, Motivation, Objectives of 

project, Scope of studies, Expected Outcome to introduce our Project. 

Second Chapter: In second chapter we describe Introduction of Background, Related Works, 

Comparative Studies, Scope of Problem, and Challenges. 

Third Chapter: In chapter three we mention our Required Hardware and Software and their 

specification. 

Fourth Chapter: In this chapter we implement our design and configure these design also server 

configuration. We discuss about server such as Windows server, File Server, iSCSI Server. 

Fifth Chapter: In this Chapter we tested our network after Implementation that is network working 

in system. 

Sixth Chapter: Our project comes to an end with the conclusion chapter. In this chapter we write 

about our future plan, final words etc. 
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CHAPTER 2 

BACKGROUND 

2.1 Introduction 

The background of our networking project is very simple. We just wanted to easier the network 

infrastructure design to corporate office level which will represent a system which are secure and 

faster. Everyone knows that, each part of communication is depend on networking system. 

Regularly the offices and companies use their old infrastructure design which are vulnerable and 

also have communication lagging to connect with other branches or head offices. There is data 

sharing, accessing, transferring and so on problem. The system we designed after implementing 

that will make easier the communication system. That will provide a smooth and secure services 

which will be accelerate the working through this network system. 

In this system, head office can be monitor other branches, their work, and their update. The 

branches can send information, get access, data sharing, transferring over this network privately. 

The design belong with very efficient security system that makes the network system invulnerable 

also protect important data and files. 

After all of these effort when the project is done and we will look that the customers are happy by 

this project then there was an absolute feeling of satisfaction which is a lot to us. 

 

2.2 Related Works 

Design and Simulation of Banking Network System: The banking system growth day by day 

and bring many security issues and increasing cost of implementing higher security system for 

both online banking user and the bank also their branches. In this modern age, the bank system 

update their networking sector between head office and their branches also online banking user.  

Several bank of Bangladesh, have been attacked many times by hacker [1]. After these attack the 

bank simulate the network system which are more secure than previous. 

We are influenced by Design and Simulation of Banking Networking System. We followed the 

design of banking system to implement this project. But this project is completely different.  
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Design Implementation and Monitoring of an ISP’s Network: The ISP Xenial Brodband in 

Baridhara area of Dhaka [2], monitoring their customers and bandwidth provider though a network 

system. Which have a good infrastructure design. They also provided some extra services through 

this network system like FTP Servers. 

We also influenced by their network system. We collect some data to implement our project. But 

our project is completely different. 

 

2.3 Comparative Studies 

We are influenced by Design and Simulation by Banking Network System and ISP Network 

System. So we studied a lot about these two Network System to implement our project. In Banking 

Network System have improvement than previous network system. Now the system connected in 

a private network system where communicate between their branches and head office also online 

banking user. The system are now more secure. 

We influenced by this two Networking System, but there is no similarity in our project. Our project 

is also based on same system as they use, but the infrastructure design and many extra services are 

totally different from their system. And we followed the better security system using by hardware 

devices and software packages like Firewalls, VPN, NAT, etc. Our project also provide some extra 

services which modernize this project and being user friendly. We collect data from these two 

system and we find that how to improve and how to provide a better services then which are belong 

in this market level. 

 

2.4 Scope of Problem 

In the time of internet, with the easy availability, every system has under the threat. The system 

attacked by several hacker in several times. The insecurity of system user doesn’t feel safe. Not 

only user sometimes government networking system attacked by hacker. Also trafficking of 

system slow down the slow down the system. That can be make a major problem in a corporate 

office because they depend on this system where they need a better optimized and enough secured 

network system. 
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But in our project we try to include something that make sure the system is more secured and 

faster. The design will attract corporate offices to get better communication platform also. We 

designed this to provide not only network system also have the extra services like faster 

transferring, transmission, quick responsive, etc. 

2.5 Challenges 

At the time of designing our project we had faced a lot of challenges. During COVID 19 we didn’t 

get proper guideline, we didn’t managed any lab. Causes of lockdown we shifted our hometown 

where we faced huge internet connection issues. Also we have communication issue to each other. 

We faced major problem that we didn’t arranged the requirement instrument and required machine 

to configure. Then we choose virtual simulator GSN3 to implement the design. After implement 

we had face the other problem that to taste the project. Then we create virtual machine in one pc 

and tasted the project. We know how to overcome and finally we did it by grace of Almighty. 
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CHAPTER 3 

REQUIREMENT SPECIFICATION & USAGE  

3.1 Hardware Requirements 

 For making a networking project, a pc must need a minimum hardware requirement. There is 

Figure 3.1 about hardware requirement which is shown below. 

Figure 3.1: Hardware Specification 

Processor: Intel(R) Core(TM) i5-5200U  

CPU:  2.2 GHz 

RAM:  8.00 GB 

GPU:  4.00 GB 

We face several issues while render the project for low configuration PC. 
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3.2 Project Requirements  

Table 3.1: Implementation Tool 

Logo of Tools Product of Tools Usage Work Exp. 

 

Cisco[4] Cisco Managed 

Switch 

Connecting 

Devices 

 

 

MikroTik[5] MikroTik 

Ethernet Router 

Internet Explore Routing and 

Routed 

 

Cisco Cisco Router Networking 

Device 

Routing and 

Routed 

Software Requirements 

 

Microsoft[6] Windows 10, 

Windows 7 

User operating 

system 

 

 

Microsoft Windows 

Servers 

Establish   

Server 

 

 

GSN3[7] Simulator Design 

Implement  

 

 

MikroTik Winbox GUI 

Configuration 

 

 

VMware[8] VM Ware 

Workstation Pro 

Version 16. 

To make virtual 

Computer 

 

 

In Table 3.1 we mentioned Networking Devices and Software are used in this project. We used 

also some software and hardware devices which we didn’t mention on Table 3.1 but we used these 

device and software to implement this project.  
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3.3 Switch 

 

Figure 3.2: Cisco Switch  

 

Figure 3.2 Cisco Switch 

We use some switches in our project to implement. We choose cisco switch, the switch design by 

cisco is too relible and give better services. Basically Network Switch used for to connect 

networking devices in a particular platfrom like a computer connect to printer, router, server, other 

resources.  

Systems Administration is the need to some component for the switches, and switches that let our 

connection associate at least one PCs to another PCS, even various systems. A network switch that 

operates in the Data Link Layer of OSI model. Which are belong Layer 2 of OSI model. A 

networking switch is also known a switching hub, bridging hub, MAC Bridge, etc. This is a device 

on a network. Which using packet switching to receive and sent again data to the destination 

device.  
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3.3 MikroTik Router 

 

Figure 3.3: MikroTik Router 

 

Figure 3.3: MikroTik Router 

In Figure 3.2 we mention a router which developed by MikroTik. The name of the device MikroTik 

router. This is the major device in our project we use most. We choose use to MikroTik Router 

because the capability of this router. The MikroTik Router is a more powerful device than other 

routers, which has many good reason to use, including internet sharing and bandwidth control. It 

is a device like a switch/router, ranging in size from a small box to a large box. This device has 

one port for the internet connection and LAN port for local area network as like other routers. This 

router will act as an internet sharing server and is possible to use multiple devices on the same 

network using this device. 

MikroTik Operating System (ISO): The developers of MikroTik Router have also developed it as 

an operating system.  

Why we choose MikroTik Router the answer given below: 

• Easily Bandwidth control and distribution, 
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• Auto system backup, 

• Filtering, Firewalls, Hotspot, OSPF, MPLS Routing, 

• Winbox graphical interface, remote,  

• Website Blocking, 

• Easy Monitoring, 

• Virtual Private Network (VPN), 

• Various benefits including load balancing. 

3.5 GSN3: Graphical Network Simulator 

Figure 3.4: GSN3 

In Figure 3.4, we mention the Graphical Network Simulator (GNS3). Where can design high 

quality and complex network topology. Basically it’s used for to emulate, configure, test and 

troubleshoot virtual and real network. The simulator can run in low configure pc. GNS3 is an open 

source software which can download and use free. That support multiple switching, routing option. 

The availability of each and every networking devices. The configuration process are easier 

comparatively. Even some devices are pre –configured and optimized. 
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During COVID 19, we faced some major issues. We didn’t arrange the devices, machine, PCs, 

resources. That’s why we choose for a Simulator for implement this project. We used the devices 

for free whatever that was easy to configure in this platform. There are some simulator like Cisco 

Packet Tracer, Boson Netsim, EVE-NG, etc. But we choose to implement on GNS3. Some features 

of GNS3 attracted us. 

 

There are some features of GNS3: 

• Design of high quality and complex network topologies. 

• Packet capture using Wireshark. 

• Simulation of simple Ethernet, Frame. 

• GNS3 supports devices and IOS of more vendors. 

• Easy to hardware emulation 

• Connect and simulate VMware/Virtual Box to GNS3 and can create some of 

complex network labs. 

• We can design network diagram and can represent network architecture easily. 

 

3.6 Winbox 

Winbox is a small utility software application which allow administration of MikroTik RouterOS 

using simple graphical user interface. Winbox Manage and configure MikroTik RouterOS. We 

choose Winbox to configure our router because in Winbox has some interesting features and 

services such as easy to configure devices and manage these devices. We used Winbox to 

configured MikroTik Router. 

There are other some alternatives of Winbox but in the worst scenario comparatively easy to use 

and reliable to get expected outcome.
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CHAPTER 4 

DESIGN AND IMPLEMENTATION 

4.1 Design a Network 

Below the Step of project that define network design. It will fulfill all of the requirement of any 

w

Figure 4.1: Network Design Process 

In Figure 4.1 state that a process of designing network. This diagram show what are these step to 

designing network. 

4.2 Backbone Network Design 

To design a netwrork, we would like to follw some rules make it more economical and provides 

high perfomance. There are some goal that squeare a designed network that mention earlier. 

• Confidentiality  

• Availability  

• Scalability  

• Security 

To get better outcome a network should be well engineered that enable flexibility and growth. 

We try to manage.
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4.3 Overall design of a Network Planning  

 

Figure 4.3:   Overall Design of Network Planning for Corporate Office 

 

 In Figure 4.3 state that Overall Design of Network Planning for Corporate Office. We designed 

this Network Infrastructure for corporate office as our final year project. We designed this project 

on a simulator which name is GNS3. 

Some important info given below about our designed Network planning: 
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• The mentioned Image above shown that it consist with several WAN and LAN and 

its Head office and their branches and servers. Servers and Head office and their 

branches communicate each other via internet.  

• We can see in Figure 4.3 that the server and Offices associated by using routers and 

switches. 

• In Figure 4.3 we see a small connecting using some workstation and server is LAN 

stands for Local Area Network.  

• Here we see another network connected to internet that consist with three branch 

office and every branches workstation .This is WAN stand for Wide Area Network. 

4.4 Layer Network 

 

Figure 4.4: Layer Network of Designed Project 

 

4.5 Design Implementation on Head Office 

At first we implement our design to organize Head Office. Our step to implement design for Head 

Offices are need to establish Internet Connection, Installation of Networking devices, 

Configuration of Networking Devices, Checking Connectivity to get expected outcome. Instance 
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get information from a reputed ISP to establish connection like IP Address, Subnet Mask, 

Gateway, and DNS and so on.  

4.6 Internet Connectivity  

To implement the design we must need a good internet connection. In this design, we used several 

networking devices which need a strong and reliable internet connection to associate each other. 

So, we explore a package of corporate offices. Which are provided by AMBER IT LTD [9]. The 

package specially featured for corporate purpose. There are some features of ISP that are Real IP, 

Free Talk Time, Reduce Call Costs, Redundant Link, Safe DNS, and Video Conferencing and so 

on. 

 

Figure 4.6: Internet Connectivity 

In Figure 4.6 shown that we taking broadband connection to our head office which provided by 

Amber IT.  

Connection Information: 

IP Address:  192.168.101.156 

 Subnet Mask:  255.255.255.0 

 Gateway:  192.168.101.254 

 Primary DNS:  8.8.8.8 
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4.7 Local Area Network of Head Office 

 

Figure 4.7: Local Area Network Connection  

In Figure 4.7 that shown local area network of head office. It is a group of associate Networking 

Devices that share a common communication channel or wireless to communicate a server or user. 

LAN encompasses computer and peripherals associate a server or among head office. User of head 

office use LAN affiliation to share resources such as DC Server and Other servers to PCs. 

In Figure 4.7 shown that the design, we used MikroTik Router which combined with another 

MikroTik router which also associate with SW1 then SW2 which connect HR-1 and several 

servers. And also use another switch Sw4 to extend some servers. Sw4 switch also connecting user 

which is IT-1. 

 

 

 

 

 



 

 @Daffodil International University  19 

4.8 LAN Configuration for Head Office 

 

Figure 4.8.1: DHCP configuration 

In Figure 4.8 we configured DHCP for Head Office Router 2. We follow certain steps to configure 

DHCP for Head Office Router 2 which given below. 

 

DHCP Configuration Procedures: 

➢ Step-1: 

 Login into head office main router through Winbox. 

➢ Step-2: 

IP> Addresses > ether3 > 192.168.5.1/24 > enable > apply > ok. 

➢ Step-3: 

IP> DHCP Sever > DHCP Setup > DHCP Interface > ether3 > DHCP Address > 

192.168.5.0/24 > Gateway > 192.168.5.1 > Address to give out > 192.168.5.2-

192.168.5.254 > DNS > 8.8.8.8 > lease time > 24:00:00 > ok. 

➢ Step-4: 

IP > Firewall > NAT > Action > Masquerade. 
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Figure 4.8.2:  WAN and LAN Connectivity in Head Office 

In Figure 4.9 establish WAN and LAN Connectivity for Head Office router 2. In figure shown 

that DHCP Client and DHCP Server Setup. We follow some step to establish connectivity for 

Head Office. The steps are given below. 

WAN Connectivity through DHCP Client: 

➢ Step-1: 

Login into Head Office router 2. 

➢ Step-2: 

IP > DHCP Client > New DHCP Client > Interface > ether1 > Enable > Apply > 

Ok. 

DHCP Server Setup: 

➢ Step-1: 

IP > DHCP Sever > DHCP Setup > DHCP Interface > ether2 > DHCP Address > 

10.1.1.0/24 > Gateway > 10.1.1.1 > Address to give out > 10.1.1.2-10.1.1.254 > 

DNS > 8.8.8.8 > lease time > 24:00:00 > Ok. 

➢ Step-2: 

IP > Firewall > NAT > Action > Masquerade. 
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Machine Connectivity: 

➢ Step-1: 

Login DC Server  

➢ Step-2: 

Go to Internet and Network setting > Change Adapter Setting > Ethernet > Properties 

> IPV4 > Obtain an IP address automatically > Obtain DNS server address automatically > 

Apply > Ok. 

 

Now each of devices of LAN will get IP from DHCP Server. Now need to check connectivity that 

configuration are ok. 

Connectivity Check: 

➢ Step-1: 

Open cmd > type ‘ping google.com’ > Enter. 

Figure 4.8.3: Connectivity Check 

In Figure 4.8.3 we tested LAN Connectivity. We can see in shown image we type “ping 

google.com” on cmd. The outcome ensure that the connection established. Our configuration are 

all ok. 
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4.9 Design implantation on branch 1 

 

 

Figure 4.9: Design Implementation for Branch 1 

 

According to Figure 4.9, we got some static IP from Head Office to connect Branch1. We used a 

switch which associate with IT2 then connect with a Cisco router which make internet connection 

with user by using another switch. To configure Branch1 we need addresses to assign and 

configure Cisco router. 
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4.10 Branch1 Configuration  

 

Address Assign for Branch1 

 

Figure 4.10.1: Address Assign for Branch1 

In Figure 4.10.1 we assigning Addresses for Branch 1 on head office. The configuration procedures 

of Static IP given below. 

Static IP configuration: 

➢ Step-1: 

Login into Head Office main router through Winbox. 

➢ Step-2: 

IP > Addresses > ether2 > 10.1.1.1/24 > enable > Apply > Ok. 
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Addresses Assign for WAN Connectivity 

 

Figure 4.10.2: Add Assigning for WAN Connectivity for Branch1 

In Figure 4.10.2, we assigned addresses to Branch1 main router for set up WAN Connectivity. 

Configured with static IP from Head office. The processes are mentioned below. 

Connection through Static IP: 

➢ Step-1: 

Login into Branch1 main router through Winbox. 

➢ Step-2: 

IP > Addresses > ether1 > 10.1.1.2/24 > Enable > Apply > Ok. 
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Branch1 Static Configuration 

 

Figure 4.10.3: Branch1 static configure 

In Figure 4.10.3 we assigned Gateway and DNS through Static IP. Previous Figure 4.10.2 we 

assigned address to initiate connection through static IP. Now we need to configure by allocate 

Gateway Addresses and DNS. 

Gateway and DNS Assigning  

➢ Step-1: 

IP > route > gateway > 10.1.1.1 > Ok. 

➢ Step-2: 

IP > DNS > 8.8.8.8 > Ok. 

Connectivity check for branch1 

➢ Step-1: 

Go to cmd 

➢ Step-2: 

Type ‘ping google.com’ 
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Figure 4.10.4: Connectivity Check Branch1 

In Figure 4.10.4 ensure that the connection are established. 

Address Assign for Cisco Router 

We used a cisco router in our Branch1. We assigned addresses then we configured the router. 

 

Figure 4.10.5 Address assign for Cisco Router 
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In Figure 4.10.5 state that we used a Cisco router in Branch1 which build connection from Head 

office. The router connect Branch1 user into Network System.  

Assigning Address Procedure on Cisco Router for Branch1 

➢ Step-1: 

Login into Branch1 main router through Winbox. 

➢ Step-2: 

IP > Addresses > ether2 > 192.168.4.1/24 > Enable > Apply > Ok. 

➢ Step-3: 

IP > DHCP Sever > DHCP Setup > DHCP Interface > ether3 > DHCP Address > 

192.168.4.0/24 > Gateway > 192.168.4.1 > Address to give out > 192.168.4.2-

192.168.4.254 > DNS > 8.8.8.8 > lease time > 24:00:00 > Ok. 

➢ Step-4: 

IP > Firewall > NAT > Action > Masquerade. 

Now, Addresses are assigned in Cisco Router of Branch1. 

 

Configuration of Cisco Router for Branch1 

➢ Step-1: 

Open Cisco Router Console 

➢ Step-2: 

Type Command for WAN connectivity. 

Command: 

CiscoR#conf t 

CiscoR(config)#IP domain lookup 

CiscoR(config)#int f0/0 

CiscoR(config)#IP add dhcp 

CiscoR(config-if)#no sh 

CiscoR(config-if)#exit 

 

CiscoR(config)#int f0/0 

CiscoR(config-if)#IP nat outside 

CiscoR(config-if)#exit 

CiscoR(config-if)#int f0/6 

CiscoR(config-if)#IP nat inside 
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CiscoR(config-if)#iexit 

CiscoR(config)#IP access-list standard 1 

CiscoR(config-std-nacl)#permit any 

CiscoR(config-std-nacl)#exit 

CiscoR(config)#IP nat inside list 1 int f0/0 overload 

CiscoR(config)#exit 

 

➢ Step-3: DHCP Configuration for Branch1 users under Cisco Router 

 

Commands: 

CiscoR(config)#int f0/6 

CiscoR(config-if)# IP add 10.1.1.1 255.255.255.0 

CiscoR(config-if)#no sh 

 

CiscoR(config-if)# IP dhcp pool 1 

CiscoR(dhcp-config-if)#network 10.1.1.0 255.255.255.0 

 

CiscoR(dhcp-config-if)# default-gateway 10.1.1.1 

CiscoR(dhcp-config)# dns-server 8.8.8.8 

 

Now Cisco router is configured by above command. Which commanded from CLI. 

 

User connectivity 

After configured Cisco Router we need to connect user to the network of Branch1 for they can use 

internet connection. The steps are mentioned below that how initiate user connectivity. 

➢ Step-1: 

Boot and Sign in into User Machine  

➢ Step-2: 

Go to Internet and Network setting > Change Adapter Setting > Ethernet > Properties > 

IPV4 > Obtain IP Address Automatically > Obtain DNS Server Address Automatically > 

Apply > Ok. 

Check Connectivity 

After Configured Cisco router and also ensure User connectivity we should to check that user of 

Branch1 getting internet. To check the internet of Branch1:  

Open Terminal Type ‘ping google.com’ > Enter. 
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4.11 Design Implementation for Branch2 

 

Figure 4.11: Overall Design for Branch2 

According to Figure 4.11, by using PPPOE we connect Branch2 and Head Office. PPPOE stand 

for Point-to-Point over Ethernet. The overall design of Branch2 state that the design to connect 

each device to on a network which associate with Head office. From Head Office can monitor 

Branch2. Devices Installation and Configuration processes explain below. 
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Why We Choose PPPOE? 

Point-to-Point over Ethernet refers to the system used in connecting multiple devices, computer, 

laptop, smartphone and so on an Ethernet Local Area Network (LAN). The main purpose of PPPoE 

used in a building or office allow that user can share a common digital subscriber line. PPPoE has 

some specified features. That’s why we choose to use this system. The feature of PPPoE are 

mentioned here. 

Advantages of PPPoE: 

➢ Easy to Configure  

➢ Support Multiple Devices and Users on a local area network (LAN) 

➢ Authentication, Encryption, Data Compression 

➢ Widely Deployed and 8 bytes Header 

➢ DHCP Based on User Login 

4.12 PPPOE Server Configuration  

i. Address Assigning in PPPOE 

 

Figure 4.12.1: Assign PPPOE IP Addresses 
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PPPOE IP Address Assign: 

➢ Step-1: 

Login into Head Office Main router through Winbox. 

➢ Step-2: 

IP > Addresses > ether2 > 10.1.1.1/24 > enable > Apply > Ok. 

In Figure 4.12.1 above mentioned, we need to assign IP Addresses to configure PPPOE Server. 

 

PPPOE Server Configuration: 

ii. PPPoE Profile Generate  

 

Figure 4.12.2: PPPOE Profile Generate 

Configuration of PPPoE Profile Generate: 

➢ PPP > Profile > General > Name > Profile1 > Local Address > 10.1.1.1 > Remote Address 

> 10.1.1.2 > Apply > Ok. 
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iii. PPPoE User Generate 

 

Figure 4.12.3: PPPoE Secret/User 

Configuration of User  

➢ PPP > Secret > Name > user1 > Password > user1 > Service > PPPOE > Profile > Profile1 

> Local Address > 10.1.1.1 > Remote Address > 10.1.1.2 > Apply > Ok. 

 

iv. PPPOE Server Generate  

Configuration of PPPoE Server: 

➢ PPP > PPPOE Server > Server Name > service1 > Interface > ether2 > default profile > 

profile1 > Apply > Ok. 
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v. PPPoE Client configuration: 

 

 

Figure 4.12.4: Configuration of PPPOE Client 

Configuration of PPPoE Client: 

➢ Step-1: 

Login into Branch2 router through Winbox. 

➢ Step-2: 

PPP > Interface > PPPOE Client > Dial Out > User > user1 > Password > user1 > Apply 

Ok. 

Connectivity Check of Branch2: 

➢ Open cmd  

➢ Command: ping google.com 

We need to check that Branch2 internet connection that are established by above command. 
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4.13 Windows Server Installation  

In our designed Network Infrastructure, we used several server such as Windows Server, File 

Server, ISCSI Server, etc. So we need to install and configure our servers. We install these servers 

in our Virtual Machine. 

Firstly we installed Windows Server. The version of Windows Server is Windows Server 2019. 

We install the server in VM Machine due to physical opportunity. Windows Server 2019 is a one 

kind of operating system which use as a server. The installation process are same as like how we 

install operating system in our Pc. 

4.14 ADDS Install in Windows Server 

Active Directory Domain Services (ADDS) is a server role in Active Directory. Active Directory 

helps that organize our office’s users, computer and more. IT admin of Head Office uses Active 

Directory to organize our office’s complete hierarchy from which computers belong on head office 

network. There are to division to install Active Directory Domain Services on Windows Server 

System mention are below. 

Prerequisite of ADDS Installation 

➢ Assign Static IP Address  

➢ Set strong Administration Password 

➢ Set Time zone 

ADDS installation processes  

➢ Open Server Manager  

 

➢ Server Manager > Dashboard > Manage > Add Roles and Feature > Installation Type > 

Role based > server selection > current server > Server Roles > ADDS > Features > Default 

Features > Overview > Install > Result > Restart Machine. 
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Figure 4.14.1: Selecting ADDS Role 

In Figure 4.14.1, Shown that Selecting Active Directory Domain Services (ADDS) Role. 

4.15 Promote Server as a Domain Controller  

• Server Manager > Dashboard > Task > Promote this server to a Domain Controller > 

Deployment Configuration > Add a new forest > domain > mindoptimizer.local > domain 

controller options > Set DSRM Password > DNS Option > Additional Option > Path > 

Review Options > Prerequisite Check > Install > Installation > Result > Restart Machine. 

 

Figure 4.15.1: Server to Domain Controller  
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In Figure 4.15.1 mentioned that the promoting of Windows Server 2019 as a Domain Controller. 

Domain Controller Promotion is a tool in active directory which install and removes ADDS and 

promotes domain controllers. 

 

After Promoting to DC (Domain Controller) 

 

Figure 4.15.2: Promoted server as a Domain Controller 

Domain Joining in Windows Operating System 

 

Figure 4.15.3: Attaching Domain with OS 
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We follow some procedure to joining Domain into Operating System and mark in Figure 4.13.4. 

• Go to Setting > about your PC > Properties > Computer Name > Change > Member of > 

Select Domain > mindoptimizer.local > Ok. 

For approval of Domain User need to provide DC Username and Password. (We can do it via into 

specific user). By the same process we can associate each machine to Domain Controller. 

4.16 Organizational Unit, Groups, User Creating 

• Go to Server Manager > Tools > Active Directory Users and Computer > Expand 

mindoptimizer.local > Right Click > New > OU > Name > IT > Ok. 

• Right Click on OU > New > User >First Name > IT > Last Name > 1> Username > it1 > 

Password > Confirm Password > Check in User can’t change password > Ok> Finish. 

• Right Click on OU > New > Groups > Group Name > it > Group Scope > Global > Group 

Type > Security > Ok. 

• Right Click on user it1 > Add queue group > select group it > ok. 

We can create multiple Organizational Unit (OU) groups, user though CSV File in windows 

PowerShell. 

User Login via Domain User  

Boot User Machine > Username > it1@mindoptimizer.local > Password > admin@i1 > hit 

Enter. 

 

Figure 4.16.1: Sign in with Domain User 
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In Figure 4.16.1 sign in machine with domain user which we Create d above. 

Check Domain User  

 

Figure 4.16.2: Check Domain User Presence 

After Sign in with domain user of Branches. To ensure that domain user can their work in the 

network. Above Figure 4.16.2 ensure that the domain user who login into server are correct. 

4.17 File Server 

File Server is a one kind of server that provides access to files. File Server take action as main file 

storage location that can be access by multiple users. A file server could be dedicated system as 

like NAS which means Network attached Storage Device, or it can be simply a computer that host 

share computer. 

 

In our design, we create a file server which monitoring by Head office. Such as corporate office 

they can easily work with the same document, spreadsheet and other data.  

File server Installation 

➢ Open Server Manager  

➢ Server Manager > Dashboard > Manage > Add Roles and Feature > Installation Type > 

Role based > server selection > current server > Server Roles > File Storage Service > 

Expand >File and ISCSI Service > Expand > File Server Recourse Manager > Features > 

Default Features > Overview > Install > Result. 
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i. File Server Role Selection  

 

Figure 4.17: Role Selection for File Server 

In Figure 4.17, we select the file server role from windows features. To installation of File Server 

we must need to add server role. After selecting role we check that the role is installed in our 

windows feature then we configure the server from server manager. 

4.18 File Server Configure 

To install File Server in our system. We need to follow some step. After installing File Server 

Resources Manager (FSRM) the major part of server installation that configuration of File server. 

There are few steps below that can create a file server on our system. 

i. Create Quota Template: Configuration of File server, firstly we need create quota template. 

We Create Quota Template by using following step that given below. 

➢ Go to Server Manager 

➢ Server Manager > Tools > FSRM > Expand Quota Management > Create Quota Template 

> Template Name > Storage > Limit > 50 Gigabyte > Hard Quota > Notification Threshold 

> Add > Event Log > Check in Send warning to event log > Report > Check in Generate 

Report > Check in duplicate files, file screening, large files > Ok. 
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Figure 4.18.1: Creating Quota Template 

After Creating Quota Template to share Folder where Domain user store Data.  

Go to File Manager and Create folder > File Server > Right click > Properties > Sharing > 

Advanced sharing > check in share this folder > Permission > Full Control > Add groups > it > 

Ok. 

ii. Quota Apply 

 

Figure 4.18.2: Quota Applying 
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For apply quota, Go to Server Manager > Tools > FSRM > Expand Quota Management > Quota 

> Create Quota > Drive Quota Path > Drive Properties Storage which we Create d > Create. 

iii. File Screening Management 

File Screening Management is a feature that we can control the types of files that user can store on 

a file server. We can set limit to user that can access and store. File management also blocking 

specific types of files from specific user. In our system we use once more like Head office HR 

department can access and edit specific files which worker of branches cant access. We can File 

Screening Management by using following step given below. 

Firstly, we need to Create File Screening Management Template. 

File Screening Management Template Create: 

 Go to Server Manager > Tools > FSRM > Expand File Screening Management > Create file 

Screening Management> Settings>Template Name>Block Audio and Video>Screening 

Type>Active Screening>Select file groups>Audio and Video files>ok 

Now we need to Apply File Screening after creating template. 

Apply File Screening 

Figure 4.18.3: Applying File Screening 
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In Figure 4.18.3, after creating template we applying File Screening. 

Fore applying File Screening, Go to Server Manager > Tools > FSRM > Expand File Screening 

Management >File Screens> Create Screen >Drive File Screen Path>Drive Properties which we 

Create d> Create.  

Now, we can block or compress files to multiple user. 

4.19 iSCSI Server 

iSCSI Server stands for Internet Small Computer System Interface Server is a storage networking 

protocol that easy to data transfer, share storage over IP/TCP.  iSCSI server has two part such as 

iSCSI Target and iSCSI Initiator. iSCSI target software run into iSCSI Server and define logical 

units as iSCSI target devices. In other hand iSCSI initiator run on different servers and connect to 

target server to make the storage visible that server. We configured that two part of iSCSI Server 

in our design. The configuration mentioned below.  

iSCSI Storage Target Server Configuration: 

At first we need to configure target server. For configure Target Server we need to select server 

role as like installing others server. 

 

Go to ISCSI Server Manager > Dashboard > Manage > Add Roles and Features > Installation 

Type > Role based > Server Selection > Default > Server Role > Expand File and Storage Services 

> Expand File & ISCSI Services > Check in ISCSI Target Server > Features > Default > Overview 

> Result. 

After installing Target Server it create a storage which act as backup. The installed services of the 

iSCSI storage that can never fault. If main server storage are full then head office and branches 

can use iSCSI server as a cloud server.  

iSCSI Server configuration 

Go to Server manager > File & Storage Services > iSCSI > Create New iSCSI Virtual Disk > 

Virtual Disk Location > Select Server > ISCSI Server > Select Volume > C: > Virtual Disk Name 

> iSCSI1 > Select Virtual Disc Size > 10GB > Dynamically Expending > ISCSI Target > New 
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ISCSI Target > Name > iSCSI1 > Add > Select enter a value > Type > IP Address > Value > 

10.1.1.2, 10.1.1.3 (Clients IP) > Confirmation > Result. 

 

Figure 4.19.1: iSCSI Virtual Disk Management 

In Figure 4.19.1 iSCSI Virtual Disk Management state crating iSCSI virtual Disk which can use 

multiple user if main server are full. 

Disk Enabling to Client Side 

Now need to enable that into Client Side. For enabling Disk: 

Go to disk management > select iSCSI storage > new storage > name > iSCSI-2 > OK. 

 

Figure 4.19.2: Creating iSCSI-2 Storage 
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4.20 Failover Clustering  

Failover Clustering is group of server that work together to the ensure availability and scalability 

of clustered role. The Failover Clustering is independent group where servers work simultaneously 

for increase more activity in server. Like when a server fail the failover cluster make sure same 

services from another servers.  

In our design of head office if any server fail of fault then by the failover clustering user can get 

same services from another server in the same time. The main advantages of Failover Cluster is 

without data losing server can switch if occur any problem of fail. 

Failover Clustering Configuration 

➢ Step-1: 

Need to install failover clustering feature to machine which are want to setup failover 

cluster. 

➢ Step-2: 

Each Cluster Node are must ensure that contain same iSCSI Storage. 

➢ Step-3: 

Validity Configuration Check of nodes that cluster nodes are suitable for failover 

clustering. 

Access Point for Administering the Cluster: 

After checking validity Create new cluster > Access Point for administering the cluster > Assign 

a unique cluster IP > Confirmation > Creating New Cluster > Summary > Ok. 

In Figure 4.20.1, we assigning IP for creating New Cluster from Access Point for Administering 

the Cluster which are mentioned below. 

After creating Failover Cluster by assigning two IP we have got failover cluster manager from 

where we can switch server if any server fail we can get same services from another server in the 

same time. 
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Figure 4.20.1: IP Assign for Creating Cluster 

 

 

Figure 4.20.2:  Failover Cluster Manager 
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4.21 NLB Clustering  

Network Load Balancing (NLB) Clustering is the ability to balance traffic of web server. When 

user use single channel in web server then increase the traffic of server and it’s going to slow or 

fail. In this case NLB balance the load of web server. If hundreds of user try to access the server it 

getting busy in this time NLB divided user into two channels that can be reduce trafficking in 

server. That ensure the scalability of server. In our design we configured Network Load Balancing 

which explain below.  

 

Network Load Balancing Configuration: 

• Step-1: 

Firstly need to install NLB Feature on nodes where we want to cluster. 

 

• Step-2: 

Server Manager > Tools > NLB > New Cluster > Connect to host1 > Priority > 1 > 

Dedicated IP > Add IP Address > 192.168.1.250 > Cluster Permeates > Select IP Address 

> 192.168.1.250 > Internet Name > www.mindoptimizer.local > Cluster operation mode> 

multicast > Add Port > Port Range > 80, 443 > Protocol > Both> Ok. 

 

• Step-3: 

From NLB Manager > Add Host to Cluster > Host IP Address > Priority > 2 > Finish. 

Figure 4.19 mentioned below state that Networking Load Balancing configured. 
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Figure 4.21: Network Load Balancing 

 

4.22 Group Policy Management 

Group Policy Management is an interface that simplifies administering GPOs. Group Policy 

Management has key feature that monitoring ensure limitation of user computer from admin panel 

which means GPOs uniform the user.  

 

In our design, we installed some features like worker’s machine doesn’t able to access on control 

manager that means they can’t install or uninstall any packages. We have used so many features 

like that which we are mentioned below. 

Features we used in machines under this network: 

• Prohibited Control Panel,  

• Lock taskbar, 

• Software Deployment, 

• Password Policy, 

• Audit Policy, 
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• Task Manager, 

• Inbound /Outbound Rules, 

• Disable Windows update, 

• Bitlocker, 

• Disable Local Admin, 

• User Rights Assignments 

• Mapped Driver, 

• Prohibited Changing Proxy Settings, 

• Setting the default lock screen, 

• Prevent changing background, 

• Set wallpaper, and so on. 
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CHAPTER 5 

TESTING 

5.1 What is testing? 

Network Testing, a subset of designing and development, is a whole design testing for quality 

control of network infrastructure. 

 

We tested several times to maintain quality and also check expected outcome. The testing, ensure 

that the environment of networking is working perfectly. We are giving few test case for different 

situation. 

 

5.2 Test case 1 

Test Case  : This test will be check internet connectivity Head Office and Branches. 

Test Procedure :  Open terminal and Type ‘ping 8.8.8.8’ and hit enter. 

Expected Result : Internet works perfectly in this infrastructure. 

Actual Result  : Internet connection filed on Branch1. 

Comment  : Need to check for Masquerade configuration on Firewall NAT Action. 

Masquerade not configured properly. Configure it. 

Conditional Test : Again open terminal and type ‘ping 8.8.8.8’ and hit enter. 

Expected Result : Successfully data stored. 

Actual Result  : Internet working properly. 

Accuracy  : Accuracy depends on Networking Devices. 

5.3 Test case 2 

Test Case  : Domain Controller (DC) control all the domain user perfectly. 

Test Procedure :  Try to share data in file server. 

Expected Result : Successfully data stored.  

Actual Result  : Can’t share data in file server. 
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Comment  : Networking and Sharing issue. Turn on Network Discovery and File and Printer 

Sharing. 

Conditional Test : Try again to share data. 

Expected Result : Successfully data stored. 

Actual Result  : Data shared successfully. 

Accuracy  : Perfectly accurate 

 

5.4 Test Case 3 

Test Case  : This test will check remotely connect using VPN. 

Text Procedure : Try to connect VPN connection by username and password which provided by 

VPN Server. 

Expected Result : VPN connected successfully. 

Actual Result  : Working perfectly. 

Comment  : VPN working as expected 

 

.



 

 @Daffodil International University  51 

CHAPTER 6 

CONCLUSION 

7.1 Obstacles 

A network project means a lot of experience. In this section we summarize the experience gained 

by project team during development of “Design and Implementation of Network Administration 

for Corporate Office”. At the same time, we faced so many problems. 

 

1. Working with networking devices completely a new experience for us. Normally we are 

working with simple networking, using simple devices, servers, etc. 

2. We adopt these things by video tutorials, text tutorials, and internet and learning materials given 

by the tools themselves. It's a matter of time, patience and hard work. 

3. It is very sensible work and it demands much time because the networking designing try to 

connect networking environment with the real world. 

4. Network designing is very difficult because you need to work with each and every point of the 

model. 

5. The Exists design demands vast knowledge about its properties, sections and sub-sections. 

 

After all the thing is that a networking project is not a project of 6 or 8 months for two people. 
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7.2 Achievements 

1. Now we know much more about networking device. How it works? The properties, objects and 

others. 

2. We know how design and implement.  

3. Co-Operation between group members. 

4. Develop communication skills. 

5. Growing creative thinking and imagination capability. 

7.3 Future Plan 

• Level Extension 

• Improve Hardware Configuration 

• Develop Infrastructure of Networking project 

• Introduce new environment and scenes 

• Maintenance Server  

• Now our final year project designing and implementing virtually. In future, we will make 

it using physical Devices and Server. 
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7.4 Appendices 

 

We learned a lot through this project. This project has sharpened our concept in Networking sector, 

installation devices and the software-hardware interface. 

We learned a lot about networking. The success of this project may give pleasure to corporate user 

among in our country. This project only tested our technical skills but also our temperament. 

There were times that we almost lost hope but we recovered through constant concentration and 

hard work.
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